1968 CAMARO FRONT SPRING EYE BRACKET Bolts missing ???? - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 27th, 10, 09:54 PM Thread Starter
Tech Team
Rob
 
Join Date: Nov 2008
Location: Central NJ (609)
Posts: 66
1968 CAMARO FRONT SPRING EYE BRACKET Bolts missing ????

I just picked a 68 RS-SS Camaro and after looking under neath the car I noticed the front bolts in the FRONT SPRING EYE BRACKETS were missing, It almost looked like someone cut a hole were the nut should be on the body. anybody see this before?
70ChevelleLS5 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 27th, 10, 11:01 PM
Senior Tech
Jess
 
Join Date: Nov 2007
Location: Lost Creek, KY
Posts: 1,355
Re: 1968 CAMARO FRONT SPRING EYE BRACKET Bolts missing ????

They have a j nut that slips on the metal. Then the bolt screws into it. They are bad to rust and break when trying to replace the rear end. They make them repro. Two of mine broke, just replace them with the new bolts and nuts. I put the blue thread lock on them, and then coated with white grease once put in to keep from rusting agian...

Jess67
67 Camaro Blue 427, 4-speed, 12 bolt
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 Camaro 350, 200-4R, PS, AC, PB, IN PARTS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jess67 is offline  
post #3 of 3 (permalink) Old Apr 28th, 10, 12:01 AM
Senior Tech
 
Join Date: Jun 2006
Location: Washington State
Posts: 479
Re: 1968 CAMARO FRONT SPRING EYE BRACKET Bolts missing ????

not sure on the torque specs for the j nuts but be careful when tightening them i had a couple new ones break on me. i was going to try and make something different for them if i cant get some more new ones to snug up.

Rich


67 that is asleep right now but is somehow my dream
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
impreza13 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome