very hard brakes - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 8th, 10, 04:47 PM Thread Starter
Tech Team
 
Join Date: Sep 2006
Posts: 62
very hard brakes

1966 velle,dual master cylinder and booster. front disc, rear are drums, vacum to the intake and good vacum, I have a poportioning value with no dail in tuning it, but theres a black cap on the front of it ,when i removed it theres a small nut that turns is that the adjustment, cant hardly stop ,,the brakes are that hard.
__________________
jjjcamaro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 8th, 10, 05:40 PM
Senior Tech
Brandon
 
Join Date: May 2004
Location: Monroe, NC
Posts: 2,090
Garage
Re: very hard brakes

check to make sure that the vacuum line is hooked up.. It sounds like your booster isn't getting the vacuum it needs to help it work. How is the peddal when the motor is off? Other thing, is it the right plunger rod for the application.. If it's too long then the MC piston is already compressed into its bore and has no where else to go.

Run the motor for a bit. shut it off then apply the brakes.. You should hear a whoosh sound and the peddal should collapse. If neither of these occurr then it's likely the wrong rod is installed. If the peddal collapses and no whoosh sound, then it's likely the adjustment is wrong or booster is going bad.

Brandon J. licence 1NASTY67

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nantooch is offline  
post #3 of 5 (permalink) Old May 8th, 10, 05:59 PM Thread Starter
Tech Team
 
Join Date: Sep 2006
Posts: 62
Re: very hard brakes

theres no swoosh or any funny noise. the brakes are the same if engine is off or on, and how can i tell if the brake rod is orringanal thanks
jjjcamaro is offline  
 
post #4 of 5 (permalink) Old May 8th, 10, 09:11 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: very hard brakes

Quote:
check to make sure that the vacuum line is hooked up.. It sounds like your booster isn't getting the vacuum it needs to help it work.
Yep

Quote:
the brakes are the same if engine is off or on,
Confirms

If the pin is too long, the brakes dont release
If too short, have stuff all or no brakes,

Basic test for the booster is pump the pedal a few times, hold down, turn the engine on and the pedal will move down a little.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #5 of 5 (permalink) Old May 13th, 10, 01:58 PM
MCB
MCB Parts
 
Join Date: Dec 2009
Location: Danville, Ca.
Posts: 953
Re: very hard brakes

Sounds like a bad booster, thats the #1 complaint we hear, rock hard pedal but the car doesn't feel like it will stop. Can you hear any vacuum leaking inside the car with motor running?
MCB is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome