CalTracs - Subframe Connectors - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old May 23rd, 10, 07:31 PM Thread Starter
Senior Tech
 
Join Date: Sep 2009
Location: Oklahoma
Posts: 350
CalTracs - Subframe Connectors

Anyone have a problem with there CalTracs hitting the subframe connectors?
I can use the bottom hole but not the top hole, the bolt hits the subframe connectors.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
camaro434 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old May 23rd, 10, 07:39 PM
Gold Lifetime Member
Jim
 
Join Date: Nov 2006
Location: Maine coast
Posts: 1,290
Re: CalTracs - Subframe Connectors

Will let you know in a week. Mine are sitting in the garage right now, waiting for me.
What kind of SFCs are you using? I have Global Wests installed. Not welded up on the rear frame rails yet.

Jim
Hanging on the Maine Coast...moved back North

1969 RS/SS, 383, 4spd, 373s, 12bolt, FatMat, Vintage Air - Super Red, and it's my first Camaro.
Engine pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Radiator pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Build album

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lobstah is offline  
post #3 of 13 (permalink) Old May 23rd, 10, 07:42 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: CalTracs - Subframe Connectors

No problem at all... I will post some pics in a sec.

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
 
post #4 of 13 (permalink) Old May 23rd, 10, 07:48 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: CalTracs - Subframe Connectors

This notch will clear the top hole.







I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
post #5 of 13 (permalink) Old May 23rd, 10, 08:16 PM
Senior Tech
Ryan
 
Join Date: May 2008
Location: Houston Tx
Posts: 379
Re: CalTracs - Subframe Connectors

Jeez skip...dont you ever wash that thing?

1969 X66
1964 Corvette 327/300
1998 SS Vert
1987 Regal


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hatdragracer is offline  
post #6 of 13 (permalink) Old May 24th, 10, 05:10 AM
Gold Lifetime Member
Jim
 
Join Date: Nov 2006
Location: Maine coast
Posts: 1,290
Re: CalTracs - Subframe Connectors

Really. I swear there's a spec of dust about 1" up from the pivot mount on the rod mount on that baseplate pic!

Great looking undercarriage...O/T, but what mufflers are you running?

Jim
Hanging on the Maine Coast...moved back North

1969 RS/SS, 383, 4spd, 373s, 12bolt, FatMat, Vintage Air - Super Red, and it's my first Camaro.
Engine pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Radiator pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Build album

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lobstah is offline  
post #7 of 13 (permalink) Old May 24th, 10, 06:06 AM Thread Starter
Senior Tech
 
Join Date: Sep 2009
Location: Oklahoma
Posts: 350
Re: CalTracs - Subframe Connectors

Quote:
Originally Posted by Lobstah View Post
Will let you know in a week. Mine are sitting in the garage right now, waiting for me.
What kind of SFCs are you using? I have Global Wests installed. Not welded up on the rear frame rails yet.
Hotchkis weld-in subframe connectors.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
camaro434 is offline  
post #8 of 13 (permalink) Old May 24th, 10, 09:13 AM Thread Starter
Senior Tech
 
Join Date: Sep 2009
Location: Oklahoma
Posts: 350
Re: CalTracs - Subframe Connectors

& those stupid J-nuts that hold the front leaf spring brackets is a joke, those things strip out easy. I've gone through 3 sets. A poor design by GM if you ask me. If someone has a better idea of mounting those front leaf spring brackets PLEASE let me know. They also look like it is a very weak point, I don't see how 3 bolts & J-nuts hold the leaf spring in place, especially now that I have Calvert split mono's & CalTracs. If drag racing the torque on those J-nuts has got to be bad.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
camaro434 is offline  
post #9 of 13 (permalink) Old May 24th, 10, 02:58 PM Thread Starter
Senior Tech
 
Join Date: Sep 2009
Location: Oklahoma
Posts: 350
Re: CalTracs - Subframe Connectors

Quote:
Originally Posted by Skeeter55 View Post
This notch will clear the top hole.
I have the exact same set up & it will not clear the top hole.
Click image for larger version

Name:	IMG_0230.jpg
Views:	240
Size:	37.8 KB
ID:	16010


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by camaro434; May 24th, 10 at 03:18 PM.
camaro434 is offline  
post #10 of 13 (permalink) Old May 24th, 10, 10:11 PM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: CalTracs - Subframe Connectors

Greg how much preload do you have on the caltracs. My set up clears the top hole but i have hared of others with the same problem.

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
post #11 of 13 (permalink) Old May 25th, 10, 04:55 AM
Gold Lifetime Member
Jim
 
Join Date: Nov 2006
Location: Maine coast
Posts: 1,290
Re: CalTracs - Subframe Connectors

Greg,
I've thought the same thing...seems like a major weak point, but I haven't seen any threads on here about it being a problem, so maybe it's ok?

Jim
Hanging on the Maine Coast...moved back North

1969 RS/SS, 383, 4spd, 373s, 12bolt, FatMat, Vintage Air - Super Red, and it's my first Camaro.
Engine pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Radiator pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Build album

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lobstah is offline  
post #12 of 13 (permalink) Old May 25th, 10, 06:11 AM Thread Starter
Senior Tech
 
Join Date: Sep 2009
Location: Oklahoma
Posts: 350
Re: CalTracs - Subframe Connectors

Quote:
Originally Posted by Skeeter55 View Post
Greg how much preload do you have on the caltracs. My set up clears the top hole but i have hared of others with the same problem.
Zero preload, I called Calvert Racing & they said that I should run it on the bottom hole anyway to be more parrallel, which is what I though. It is the way you weld up the SFC's, mine should have been moved foward so the notch would clear the top hole. I'm just going to leave it alone for now. Anyhow the Split Mono's & CalTrac's install went perfect. Can't wait to try it out.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
camaro434 is offline  
post #13 of 13 (permalink) Old May 25th, 10, 08:08 AM
Gold Lifetime Member
Skip
 
Skeeter55's Avatar
 
Join Date: Feb 2008
Location: CA
Posts: 6,628
Re: CalTracs - Subframe Connectors

Quote:
Originally Posted by camaro434 View Post
Zero preload, I called Calvert Racing & they said that I should run it on the bottom hole anyway to be more parallel, which is what I though. It is the way you weld up the SFC's, mine should have been moved foward so the notch would clear the top hole. I'm just going to leave it alone for now. Anyhow the Split Mono's & CalTrac's install went perfect. Can't wait to try it out.
Same here thats what they told me too, to run it parallel which gives you a longer pull rather then a hard hit... I did have mine in the upper holes at first and moved it to the lower for my street beast.

I NEED TO HIT THE LOTTERY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Skeeter55 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome