problem with delphi 600 line adapters (help please) - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 27th, 10, 09:21 PM Thread Starter
Jason
 
Join Date: Sep 2009
Location: Tucson
Posts: 7
problem with delphi 600 line adapters (help please)

I am about ready to just give up and put back in the 41 year old sloppy crap manual steering box! At least I know it works. So after switching over to power steering and ordering THREE quick ratio rebuilt power steering boxes all of which did not work properly probably due to the fact there made in china. Sorry for the rant I had to vent. So I bit the bullet and ordered a delphi 600 series steering box which had a hefty price tag for my 69 camaro. So after putting the box in the car and getting it all bolted up I was putting the line adapters in that were included with the box and the only one that fits is the high pressure side. The one for the return line is to big or the hole in the ps box is to small. I was wondering if anyone has had this problem before or would know a solution. thanks in advance for any help
leadfoot327camaro is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 28th, 10, 08:33 AM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,985
Re: problem with delphi 600 line adapters (help please)

I didn't have a problem with my Delphi 600 and adapters but I remember
they were little aluminum mushroom-shaped pieces. They were not exactly alike and I had to call about which one went in which hole. They sit recessed in the box's ports as a mushroom would grow on the ground. I hope that helps you.

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
post #3 of 5 (permalink) Old May 28th, 10, 01:53 PM Thread Starter
Jason
 
Join Date: Sep 2009
Location: Tucson
Posts: 7
Re: problem with delphi 600 line adapters (help please)

Yea that does thanks. Because both of the little aluminum adapters we got were the same size. I guess I will have to call and have them send the right ones.
leadfoot327camaro is offline  
 
post #4 of 5 (permalink) Old May 28th, 10, 02:42 PM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,985
Re: problem with delphi 600 line adapters (help please)

I think I remember that correctly...I have an extra set that I can check at home, I will try to find them and check. It'll be worth the aggravation when you get it working.

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
post #5 of 5 (permalink) Old May 29th, 10, 07:17 PM
Gold Lifetime Member
Tom
 
Join Date: Mar 2008
Location: the 02176
Posts: 5,985
Re: problem with delphi 600 line adapters (help please)

Well, I couldn't find my extra set, dang it. So, I'm just going by memory but I still believe the two should be different, fwiw.

'67 rs - ordered new by my Grandfather
327 L30, K-K, Deluxe int, tach & gauges, 12 bolt posi, 4 speed.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Melrose RS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome