Cavert Split Mono without CalTracs - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 27th, 10, 04:15 PM Thread Starter
Senior Tech
 
Join Date: Aug 2001
Location: Dallas, Texas
Posts: 843
Cavert Split Mono without CalTracs

I have an all original 327/275hp 67 Camaro with an original 3.55, 12 bolt posi rear. The car came with a power robbing power glide & I changed it over to a TKO 600. I get wheel hop really bad if I try to burn the rear tires.

Since I only have 275hp, do ya’ll think the Calvert split mono leaf springs will alleviate the wheel hop trouble without also adding the CalTracs? Thanks.
327!275hp!Convt! is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 27th, 10, 06:58 PM
Gold Lifetime Member
Art
 
Join Date: Nov 2008
Location: Greentown, PA
Posts: 353
Re: Cavert Split Mono without CalTracs

I think you'd be better off with the Caltracs than the split monos. Any reason you don't want to run them? Any traction devices currently installed?

Artie

67 Camaro
99 T/A Daily Driver

Previous:
67 Camaro Traded for my 98
68 Camaro Street/Strip
98 Camaro Race car Best ET 9.08 @ 152 1.18 60'

Dyno sheets don't win races, see you at the track
SRGN is offline  
post #3 of 4 (permalink) Old Jun 27th, 10, 08:12 PM Thread Starter
Senior Tech
 
Join Date: Aug 2001
Location: Dallas, Texas
Posts: 843
Re: Cavert Split Mono without CalTracs

Quote:
Originally Posted by SRGN View Post
I think you'd be better off with the Caltracs than the split monos. Any reason you don't want to run them? Any traction devices currently installed?
I guess just keeping the original appearance & also keeping the cost down. I have read “tons” about the J.C. Whitney 3 leaf to replace the original mono leaf springs. But then I came across some reads that weren’t as favorable concerning the wheel hop issue. Next, I’m pretty sure my mono leaf springs are original to the car & fairly worn.
327!275hp!Convt! is offline  
 
post #4 of 4 (permalink) Old Jun 28th, 10, 07:57 AM
Gold Lifetime Member
Jim
 
Join Date: Nov 2006
Location: Maine coast
Posts: 1,290
Re: Cavert Split Mono without CalTracs

A friend of mine races his 68, runs mid 11's, has the original single leafs in, WITH Caltracs. No hope at all.
My Caltracs are sitting in the garage...just need to get the solid bushings pressed in...
They are black, so don't necessarily JUMP out at you...kind of sublte. Must less noticeable than the Lakewood bars I took off.

Jim
Hanging on the Maine Coast...moved back North

1969 RS/SS, 383, 4spd, 373s, 12bolt, FatMat, Vintage Air - Super Red, and it's my first Camaro.
Engine pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Radiator pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Build album

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lobstah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome