Brake problems - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old Dec 17th, 11, 12:29 PM Thread Starter
Senior Tech
Vic
 
Join Date: Oct 2008
Location: Vancouver BC
Posts: 951
Brake problems

Hi guys,

I have recently started getting problems with my brakes where when i push down on the pedal, it does not come back up, i will have to grab the pedal and pull it back up.

I am thinking it is my diaphram in my brake booster that is not responding, or could be inversed?

I have a tuff stuff booster, and got a stock master cylinder put in by my mechanic during inspection because my old on was shot...

anyways, my question is, can I get a Wilwood booster, and keep my stock master cylinder? or do i have to replace both if i want to have a wilwood? Also, my disc brakes are are stock disc's.

Vic
1969 Camaro SS
Camaro1969 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old Dec 22nd, 11, 11:00 AM Thread Starter
Senior Tech
Vic
 
Join Date: Oct 2008
Location: Vancouver BC
Posts: 951
Post Re: Brake problems

thanks for the numerous replies, always a great help

Vic
1969 Camaro SS
Camaro1969 is offline  
post #3 of 13 (permalink) Old Dec 22nd, 11, 07:21 PM
ern
Senior Tech
ern
 
Join Date: Jan 2010
Location: nova scotia canada
Posts: 171
Re: Brake problems

so did you find the problem or are you still looking, i have the same problem but i bought the complete assm.
ern is offline  
 
post #4 of 13 (permalink) Old Dec 22nd, 11, 07:36 PM
ern
Senior Tech
ern
 
Join Date: Jan 2010
Location: nova scotia canada
Posts: 171
Re: Brake problems

by the way i did not see all the replys would like to see what people are saying, i sent tuff stuff an e-mail we will see what they say
ern is offline  
post #5 of 13 (permalink) Old Dec 22nd, 11, 10:48 PM Thread Starter
Senior Tech
Vic
 
Join Date: Oct 2008
Location: Vancouver BC
Posts: 951
Re: Brake problems

hey em, it was just a snarky remark i made because i didn't get any responses.

I am assuming it is that, and i am going to replace the master cylinder and the booster with a wilwood set

Vic
1969 Camaro SS
Camaro1969 is offline  
post #6 of 13 (permalink) Old Dec 23rd, 11, 12:18 AM
Senior Tech
Filip
 
Join Date: Feb 2008
Location: New Zealand
Posts: 158
Re: Brake problems

As far as I know Wilwood doesn't make a brake booster. At one stage I had the same problem with the brakes and it turned out that the dust boot that covers the push rod was restricting it. I have since change to the Wilwood master cylinder with the Hyrdatech set up and its fantastic.
kiwicamaro is offline  
post #7 of 13 (permalink) Old Dec 25th, 11, 03:23 PM Thread Starter
Senior Tech
Vic
 
Join Date: Oct 2008
Location: Vancouver BC
Posts: 951
Re: Brake problems

yes sorry not a wilwood booster, i will have to find another after market booster.

Vic
1969 Camaro SS
Camaro1969 is offline  
post #8 of 13 (permalink) Old Dec 25th, 11, 10:41 PM
Senior Tech
Todd
 
Join Date: Aug 2006
Location: Henderson, NV
Posts: 1,664
Re: Brake problems

Factory type booster/master cylinders require a pedal return spring.
Vegas69 is offline  
post #9 of 13 (permalink) Old Dec 26th, 11, 07:41 AM
Gold Lifetime Member
Dave C
 
Join Date: Jan 2007
Location: maryland
Posts: 5,495
Send a message via AIM to Pro-Street69Camaro468 Send a message via Yahoo to Pro-Street69Camaro468
Re: Brake problems

^^^ I am on the same page as Todd^^^
Talk to Wilwood thouraly before you buy and get all your ducks in a row.

It some times takes a few days for the right answer on here especialy aroun the holidays be patient.....

PRO.ST69orange

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Pro-Street69Camaro468 is offline  
post #10 of 13 (permalink) Old Dec 26th, 11, 10:59 AM
Senior Tech
Scott
 
Join Date: Aug 2008
Location: CT
Posts: 7,286
Re: Brake problems

Quote:
Originally Posted by Vegas69 View Post
Factory type booster/master cylinders require a pedal return spring.
Factory PB systems do not use a return spring. Manual brakes do.
Sauron67MM is offline  
post #11 of 13 (permalink) Old Dec 26th, 11, 11:50 AM
Gold Lifetime Member
Mike
 
prostreet69camaro's Avatar
 
Join Date: Jul 2003
Location: Spring Texas
Posts: 5,580
Re: Brake problems

Quote:
Originally Posted by Sauron67MM View Post
Factory PB systems do not use a return spring. Manual brakes do.
Thats true,,,the booster pushes the pedal back up.

Mike
69 Camaro Prostreet - purple w/ghost flames , 502 w/ 871 blower


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
prostreet69camaro is offline  
post #12 of 13 (permalink) Old Dec 26th, 11, 09:27 PM
Senior Tech
Todd
 
Join Date: Aug 2006
Location: Henderson, NV
Posts: 1,664
Re: Brake problems

I'd have to check my assembly manual. You may be right.

Manual brakes with a Wilwood master does NOT require a return spring.
Vegas69 is offline  
post #13 of 13 (permalink) Old Dec 26th, 11, 09:48 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Brake problems

Quote:
hey em, it was just a snarky remark i made because i didn't get any responses.
The normal response is simply "Bump"
And as mentioned above holidays etc, thu it is VERY rare even then a thread is not replied to.
From memory about that time there was a very similar thread with similar issues, which we may very well have not open this thinking ..assuming double post....
Even so did u even bother to run a forum search to get some sort of answer to your problem....As mentioned this subject has arisen sevferal times over the yrs and been delt with.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome