Power Steering Conversion Issue - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Dec 19th, 11, 05:54 AM Thread Starter
Tech Team
CHOPS
 
Join Date: Dec 2011
Location: La
Posts: 58
Power Steering Conversion Issue

Ok, I've never seen this happen before. I did a power steering conversion on my 68 camaro. I used a 86z28 pump and box. Everything worked ok then the steering got really hard at low rpm and low speeds. I thought something may be clogged so I pulled the pressure valve out and checked it out. Seemed fine. Put it back together and it worked great for about 10 miles then back to the really hard steering. So I flushed the system and checked the valve again. Again, noticed nothing wrong. Put it back together and worked fine for another 10 miles then back to crappy steering. Any ideas where I should go with it from here?
BUFFDRIVER is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Dec 19th, 11, 08:44 AM
Senior Tech
Steiner
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: Power Steering Conversion Issue

Describe the way your purged the air out of it.

'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline  
post #3 of 8 (permalink) Old Dec 19th, 11, 09:47 AM Thread Starter
Tech Team
CHOPS
 
Join Date: Dec 2011
Location: La
Posts: 58
Re: Power Steering Conversion Issue

I got the front tires off the ground and went from stop to stop with the wheel until no air was seen in the fluid.
BUFFDRIVER is offline  
 
post #4 of 8 (permalink) Old Dec 19th, 11, 12:05 PM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: Power Steering Conversion Issue

It could take 25-50 turns lock to lock to bleed the air. Also make sure your lines are tight, if air is getting in anywhere it will froth the fluid.

I did the conversion with a new PS box and didn't have the inserts for the pressure and return lines on the box so I wasn't getting a tight seal. It would be fine for 15-20 minutes of driving and then it would get very hard.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
post #5 of 8 (permalink) Old Dec 19th, 11, 05:11 PM Thread Starter
Tech Team
CHOPS
 
Join Date: Dec 2011
Location: La
Posts: 58
Re: Power Steering Conversion Issue

Thanks man. I ran it lock to lock about 60 times (thanks to the help of my 6 year old daughter) with out the engine running. I got a lot of air out of it. Then I did the same thing with the engine running. I took it around the block and so far so good. I'll post the outcome tomorrow after driving it to work. Thanks again.
BUFFDRIVER is offline  
post #6 of 8 (permalink) Old Dec 19th, 11, 05:17 PM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: Power Steering Conversion Issue

Quote:
Originally Posted by BUFFDRIVER View Post
Thanks man. I ran it lock to lock about 60 times (thanks to the help of my 6 year old daughter) with out the engine running. I got a lot of air out of it. Then I did the same thing with the engine running. I took it around the block and so far so good. I'll post the outcome tomorrow after driving it to work. Thanks again.
Great, hopefully that's all it takes. However, I did the same with mine and thought it was fixed, and then I took it out for a 30 minute ride and ran into the same old problem.

Also, what are you running for hoses? One of the things that came up when I was trouble shooting was metric vs SAE fittings. Originally I was using a braided stainless hose with AN fittings, but ended up switching back to stock hoses. Two of the common metric/SAE sizes are almost interchangeable, meaning they will thread together, but may not create that perfect seal. Just another thing to check if you end up with more air in the line.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
post #7 of 8 (permalink) Old Dec 19th, 11, 05:51 PM Thread Starter
Tech Team
CHOPS
 
Join Date: Dec 2011
Location: La
Posts: 58
Re: Power Steering Conversion Issue

I'm running stock lines. Everything is from an 86 Z28. What did you end up doing after your 30 min drive with the same issue? Just re-bleed it? Anything different?
BUFFDRIVER is offline  
post #8 of 8 (permalink) Old Dec 20th, 11, 11:19 AM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: Power Steering Conversion Issue

Quote:
Originally Posted by BUFFDRIVER View Post
I'm running stock lines. Everything is from an 86 Z28. What did you end up doing after your 30 min drive with the same issue? Just re-bleed it? Anything different?
I had the same issue every time I drove it for a few weeks. I'd have to bleed it after every drive. It wasn't until I switched back to stock lines and got the correct inserts from Lee mfg. that I was able to resolve the problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome