Koni Classics - Need Priming Before Install? - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 28th, 14, 09:08 PM Thread Starter
Senior Tech
Mike
 
Join Date: Jul 2012
Location: SF Bay Area
Posts: 315
Koni Classics - Need Priming Before Install?

I've scoured the internet as well as the boards to see if I need to prime Koni Classics before I install.

I read prior to installing, the shock should be held upright while the tube is extended and compressed a few times.

I did this to the rear shock, and not sure what to expect, but the shock extends and then eventually returns to the compressed position. Do I need to continue doing this until the shock stays extended and doesn't compress on it's own?
norcal_68 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 28th, 14, 09:58 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,431
Garage
Re: Koni Classics - Need Priming Before Install?

I have Koni Classic's and have never heard of this... Mine came out of the box and bolted up after adjusting the setting to where I wanted them.

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 4 (permalink) Old Jan 29th, 14, 04:57 AM
Gold Lifetime Member
Don
 
Join Date: Jan 2005
Location: 2 Dog Town in West Texas
Posts: 11,152
Re: Koni Classics - Need Priming Before Install?

Quote:
Originally Posted by DjD View Post
I have Koni Classic's and have never heard of this... Mine came out of the box and bolted up after adjusting the setting to where I wanted them.
X2, install, adjust and forget them. They will probably outlive you.

Don
TC # 349
Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E Owner since Dec 1968

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zdld17 is offline  
 
post #4 of 4 (permalink) Old Jan 29th, 14, 10:28 AM Thread Starter
Senior Tech
Mike
 
Join Date: Jul 2012
Location: SF Bay Area
Posts: 315
Re: Koni Classics - Need Priming Before Install?

Ok, just going to bolt them up!
norcal_68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome