Bushing Lube?? - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 21st, 02, 01:47 AM Thread Starter
 
Join Date: Jun 2001
Posts: 204
Post

Getting ready to reassemble the suspension on my 68. The poly bushing kit from Energy Suspension came with 2 little containers of a white lube. What is it? I would like to buy some more and REALLY lube things up when putting it back together.

What else could I use to supplement the supplied lube?

Thanks
Robb
robbm is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 21st, 02, 04:38 AM
Senior Tech
Mike
 
Join Date: Jan 2001
Location: GARDEN GROVE CALIF
Posts: 446
Post

From what I've read. its a synthetic lube. Ethier energy or guldstrand offers a 16 oz jar of it.

------------------
Black 69 camaro
HOTROD69CAMARO is offline  
post #3 of 5 (permalink) Old Jan 21st, 02, 05:44 AM
Senior Tech
 
Join Date: Feb 2000
Location: Knoxville, TN
Posts: 503
Post

Jeg's also sells it.
Rons68 is offline  
 
post #4 of 5 (permalink) Old Jan 22nd, 02, 04:56 AM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,092
Post

Guldstrand sells NEO brand synthetic grease, it's red, slippery as snot!
David

------------------
Check my web page for First Gen Camaro suspension info:
David's Motorsports page
First Gen Suspension Page
67 RS 327 Origonal owner. 69 Camaro Vintage Racer 65 Lola T-70 Chev 350 Can-Am Vintage Racer
davidpozzi is offline  
post #5 of 5 (permalink) Old Jan 22nd, 02, 06:06 AM
BC
 
Join Date: Sep 1998
Posts: 470
Post

I'm not sure what that stuff is, but sticky as hell!! You never get enough, so I would suggest you not use it and just get some good systhetic grease from the parts store. It's much cheaper and better IMO. I had to re-do the bushings on the rear leafs in my Nova after less than a year because they were squeaking, used 'regular' moly grease and have not had a squeak yet. My PST polygraphite bushing with their grease have squeaked from almost day one! I will be trying Davids suggestion of drilling the front and installing some grease zerks to try and cure that.

Bill C.


------------------
Bill C.
Colorado Springs, CO

68 Camaro... someday!
71 Chevelle SS
70 Nova
BC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome