Hydroboost ? - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 8th, 17, 05:17 PM Thread Starter
Gold Lifetime Member
Mark
 
67 455 Bird ragtop's Avatar
 
Join Date: May 2003
Location: Melbourne, FL
Posts: 683
Hydroboost ?

Those using hydroboost. Are you using a single or double return reservoir ??

67 'Bird vert 455 JW TH400 KRE d-port 310 cfm heads H-beam rods Comp Cam 305-AH-8 cam w/1.65 rockers Ford 9" 3.55 Detroit Locker M/T Radials 31x18x15 on Convo Pro 15x15s
67 455 Bird ragtop is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 8th, 17, 09:22 PM
Senior Tech
Al
 
Join Date: Nov 2002
Location: Vancouver, USA
Posts: 10,511
Re: Hydroboost ?

I didn't modify the pump reservoir, so single. The HB return line is Teed into the pump return line close to the back of the pump. Works just fine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BPOS is offline  
post #3 of 4 (permalink) Old Jun 9th, 17, 12:14 AM
Gold Lifetime Member
Steve
 
foreverlookin's Avatar
 
Join Date: Oct 2002
Location: Pflugerville, Texas
Posts: 1,756
Garage
Re: Hydroboost ?

I tried to use a T with my original pump and it didn't seem to have enough pressure and the brakes would hang up for a second or 2. I went with a newer dual return pump that solved that problem.


Just passing on my experience.

Steve
The best laid plans are those not made (mine)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
foreverlookin is offline  
 
post #4 of 4 (permalink) Old Jun 9th, 17, 02:52 PM
Gold Lifetime Member
Lyle
 
Join Date: Mar 2015
Location: Wasilla Alaska
Posts: 151
Re: Hydroboost ?

Single. No problems so far.
akwolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome