67 Hard to steer at first - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 10th, 19, 07:20 AM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
67 Hard to steer at first

I just winterized my 67 396 with power steering. Before taking the car to the gas station and for its last right I noticed upon start up and the first time turning the steering wheel it was very tight and almost bound up eventually with more effort the wheel turned and then was turning freely as normal with no noises or sounds. The car was put together by a shop in CT seemingly on a specific budget. It was a 350/powerglide now a 396/Muncie M20. Not sure exactly what I am looking for I am 30 and did not grow up with classics at all. Do we have a difference in steering boxes SBC vs BBC? Etc.
Brent396 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 10th, 19, 11:32 AM
Gold Lifetime Member
Steve
 
Join Date: Apr 2002
Location: Southeast Pa.
Posts: 1,479
Re: 67 Hard to steer at first

See if your power steering pump belt is slipping

67RSSS......owned since 69. A basket case for most of it.
3d cad is offline  
post #3 of 4 (permalink) Old Jan 10th, 19, 02:39 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,055
Re: 67 Hard to steer at first

Belt tension and condition is always a consideration. If it get's contaminated with oil it will slip. There is a flow control valve in the outlet that may stick if a tiny shaving lodges in just the right place. A filter in the return line is a good idea. PS systems don't have filters built in so any spec of debris causes trouble.

Check my web page for First Gen Camaro suspension info:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 RS 327 original owner. 1965 Lola T-70
davidpozzi is offline  
 
post #4 of 4 (permalink) Old Jan 11th, 19, 12:34 PM Thread Starter
Apprentice
Brent
 
Join Date: May 2018
Location: Rhode Island
Posts: 23
Re: 67 Hard to steer at first

Thank you guys. I will check these. Also I am pretty sure its a pontiac pump in there.
Brent396 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome