Second set of the WRONG springs- Correct ones?? - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Feb 4th, 06, 07:14 AM Thread Starter
Senior Tech
Don
 
Join Date: Sep 2004
Location: Jackson, NJ
Posts: 746
Send a message via AIM to smith69z
Second set of the WRONG springs- Correct ones??

http://bigtyme.mygaspedal.com/photos...46327766260987

This is the second set of springs I purchased from Rick's. As you can tell in this url/pic the front has settled past respectability. Could someone let me know the manufacture and part number of springs for a 69 Z that ended up with the correct ride height?? Replacing these springs a third time hopefully will be the last

69 Fathom Green RS/Z-Endura bumper - Never finished but finally certified.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smith69z is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Feb 4th, 06, 07:23 AM
Senior Tech
 
Join Date: Feb 2000
Location: McKinney, Tx
Posts: 3,557
Re: Second set of the WRONG springs- Correct ones??

Is that fender positioned correctly?
kz1000ltd is offline  
post #3 of 9 (permalink) Old Feb 4th, 06, 07:25 AM
Team Member
Christropher
 
Join Date: Aug 2005
Location: Garland, TX (Dallas)
Posts: 7,196
Re: Second set of the WRONG springs- Correct ones??

Quote:
Originally Posted by kz1000ltd
Is that fender positioned correctly?
Looks odd to me, or maybe the paint needs to be buffed a little

Sorry I can't help you with the spring issue, but the replies at least keep the post at the top

Christropher

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
...in pieces still.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

**
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
**
MrDanB - "Don't worry about Mr.Wilcox...He has that incurable disease of thinking that they only made the Camaro in '67
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"
clwilcox33 is offline  
 
post #4 of 9 (permalink) Old Feb 4th, 06, 08:21 AM
Gold Lifetime Member
"Tri-Tip"
 
Gary L's Avatar
 
Join Date: Aug 2002
Location: Clovis , CA, USA
Posts: 10,078
Re: Second set of the WRONG springs- Correct ones??

I used a set of 6308 Moog springs. It has not settled in a year.

"Government is not reason; it is not eloquent; it is force. Like fire, it is a dangerous servant and a fearful master." ..... George Washington

Gary,TC Member with a Lemans Blue/Ivory 02D X33, DZ, M20, MS, flat hood. Only the BU code rear end is original.
Gary L is offline  
post #5 of 9 (permalink) Old Feb 4th, 06, 09:20 AM Thread Starter
Senior Tech
Don
 
Join Date: Sep 2004
Location: Jackson, NJ
Posts: 746
Send a message via AIM to smith69z
Re: Second set of the WRONG springs- Correct ones??

The gaps all line-up perfect. So the fender is installed correctly after 5 attempts :-(
I'll order the moog and try to get a refund for the springs and labor from Rick's.
Thanks!

69 Fathom Green RS/Z-Endura bumper - Never finished but finally certified.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smith69z is offline  
post #6 of 9 (permalink) Old Feb 4th, 06, 10:08 AM Thread Starter
Senior Tech
Don
 
Join Date: Sep 2004
Location: Jackson, NJ
Posts: 746
Send a message via AIM to smith69z
Re: Second set of the WRONG springs- Correct ones??

With the door half open the fender does look funky. Thanks for the help. It looks like Moog 6308's!

69 Fathom Green RS/Z-Endura bumper - Never finished but finally certified.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smith69z is offline  
post #7 of 9 (permalink) Old Feb 4th, 06, 02:52 PM
Banned
 
Join Date: Apr 2000
Location: Columbia, MO USA
Posts: 21,341
Thumbs up Re: Second set of the WRONG springs- Correct ones??

OR give Eaton Spring a call and get just exactly what you want....

I think they made the OEM springs..

pdq67



pdq67 is offline  
post #8 of 9 (permalink) Old Feb 4th, 06, 05:42 PM
Team Member
John
 
JohnZ's Avatar
 
Join Date: Sep 2000
Location: Washington, Michigan USA
Posts: 7,728
Re: Second set of the WRONG springs- Correct ones??

Quote:
Originally Posted by pdq67
OR give Eaton Spring a call and get just exactly what you want....

I think they made the OEM springs..

pdq67
Although the name is the same, there is no connection between Mike Eaton's Eaton Detroit Spring Co. and the Eaton Corporation, which is a Tier 1 OEM supplier (and has been for decades). Eaton Detroit Spring is a full-service spring manufacturing operation that can duplicate almost any spring.

JohnZ
CRG
JohnZ is offline  
post #9 of 9 (permalink) Old Feb 4th, 06, 09:09 PM
Banned
 
Join Date: Apr 2000
Location: Columbia, MO USA
Posts: 21,341
Thumbs up Re: Second set of the WRONG springs- Correct ones??

Right john,

I was talking about Eaton Corp. here.

I didn't know about the other guy?

pdq67



pdq67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome