tire & wheels that fit, and steering question - Team Camaro Tech
Wheels & Tires What fits what?

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 27th, 01, 01:04 PM Thread Starter
 
Join Date: Apr 2000
Posts: 101
Post

I just put on 225/55-16 front and 255/50-16 rear Khumo ecsta supra 712 tires on 16x8's with 4.5" backspacing. Everything fits and does not rub anywhere. They look really nice.

I just thought I would help inform some of you that want to know what does fit.

But now the steering is kind of screwy, on large sweeping left turns, everything is fine and strong, but going on right turns in the freeway there is like play in the wheel. There is no/little feeling in the wheel turning right. It is hard to explain, the problem was there before but now its worse. Should I try to adjust the steering box adjustment nut?

------------------
69 Glacier Blue Camaro w/1977 350
Shift kit, B&M Megashifter, HEI, Edelbrock 600, 10 bolt 3.08, flowmaster delta flow mufflers
http://msnhomepages.talkcity.com/rallyrd/murfys_law
Murfys_Law is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 28th, 01, 12:48 AM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,386
Garage
Send a message via MSN to DOUG G
Post

the taller tire/wheel combo. may be amplifing the problem. check your ball joints, tie rods,and control arm bushings. worth a shot.

------------------
My '68 Camaro
Doug G.
68 Camaro
406 ci.
DOUG G is offline  
post #3 of 4 (permalink) Old Jan 28th, 01, 05:33 AM
Senior Tech
 
Join Date: Jun 2000
Location: Pittsboro, NC
Posts: 534
Post

Is it power or manual steering. I had a similar problem. I adjusted my manual box and it helped some(but still needs rebuilding). I also put a new idler arm on. I took it off and put it in a vise and checked movement. WORE OUT! Put the new one on and helped even more. I had completely rebuilt my front end before changing idler and adjusting box.




------------------
Jay 69 SS-350 4-speed
Hotchkis suspension
JayBird is offline  
 
post #4 of 4 (permalink) Old Jan 29th, 01, 07:05 AM Thread Starter
 
Join Date: Apr 2000
Posts: 101
Post

Its power steering, it feels like its wandering just a little and I try to correct it and it ends up over correcting.
Murfys_Law is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome