a testy LT1 - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Feb 26th, 07, 06:22 PM Thread Starter
 
Join Date: Feb 2007
Posts: 7
a testy LT1

94 firebird changed plugs ,wires, cap and rotor. the car chokes out now when i start it it has a strong gas smell and by the grace of GOD i can get her to drive it's cool until i start giving her gas and she cuts off. i hear the pump when i turn the key but not after that if it matters it'a LT1 THANKS for YOUR TIME
david cooper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lt1 mkpatrick Bench Racing 18 Jan 22nd, 07 10:10 PM
lt1 or 30-30 cam for stock dz302? 69z28boy Performance 95 Nov 5th, 06 06:04 PM
1970 Z28 Lt1 69z28freak Engine 0 May 25th, 06 10:24 PM
1970 LT1 question nikkisdad Bench Racing 11 Feb 21st, 06 12:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome