Engine mount problem - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Jan 13th, 08, 12:24 AM Thread Starter
 
Join Date: Jan 2008
Posts: 8
Angry Engine mount problem

Just got a 69 w/350 eng.
It had broken mounts.
I installed new motor mounts
and bolted one side to frame mount
and the other side is about an inch to short to reach
frame mount bolt hole.and the pan almost touches the frame.
what is the difference between BB & SB frame mounts .
any info would be appreciated.
Thanks Daymon
dbanning is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jan 13th, 08, 07:32 AM
Gold Lifetime Member
Don
 
Join Date: Jan 2005
Location: 2 Dog Town in West Texas
Posts: 11,154
Re: Engine mount problem

Read on: http://www.pozziracing.com/camaro_engine.htm

Don
TC # 349
Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E Owner since Dec 1968

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zdld17 is offline  
post #3 of 6 (permalink) Old Jan 13th, 08, 10:08 AM
Senior Tech
Tom
 
Join Date: Jun 2001
Location: Rochester Mn
Posts: 7,749
Smile Re: Engine mount problem

There is more than just small and big block mounts. It sounds like you are using the 67/68 short and wide mounts. You need the 69 tall and narrow mounts. http://www.energysuspension.com shows the difference too. If you bought your new mounts at autozone or somewhere similar... their books are wrong.

69 Camaro -originally a LM1 car. 327, Edelbrock E-streets, hooker, DUI performance distributors, ultradyne cam, stewart, TRW etc. Vintage Air, AGR steering, Corbeau GTSII seats, 700R4 transmission, 12-bolt w/Eaton 4.11:1
TJS69 is offline  
 
post #4 of 6 (permalink) Old Jan 13th, 08, 10:34 AM
Senior Tech
 
Join Date: Dec 2003
Location: Wyoming
Posts: 1,635
Re: Engine mount problem

I have also had motor mounts that were made over seas that were way off. Not that much though...yet.
deerhunter is offline  
post #5 of 6 (permalink) Old Jan 13th, 08, 12:30 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Engine mount problem

Not only are there diff monts for diff chevy models bt there is a left and right mont, dont put then in the wrong way round.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #6 of 6 (permalink) Old Jan 13th, 08, 11:35 PM Thread Starter
 
Join Date: Jan 2008
Posts: 8
Re: Engine mount problem

lOOKS LIKE YOU ARE RIGHT
i BOUGHT THEM AT aUTOZONE
The ones they sold me were to wide and short.
After researching the great info from you guys,
I need the tall narrow mounts used on 69 350 sb
and 396 bb.
Thanks for the super replys
it helped alot
Daymon
dbanning is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome