Gas pedal problem ( Rod) - Team Camaro Tech
Engine General Engine Discussion.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old Jan 21st, 08, 01:25 AM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Gas pedal problem ( Rod)

Can anyone tell me if the 6 cylinder gas pedal will work with a sbc 327 motor as i am trying to line that linkage up, but the little arm on the engine firewall is too far toward the master cylinder. Second thing is do i need to change the whole pedal inside the car or just the engine bay side, i have swapped my inline 6 to a 327 and that is what i am facing right now, and i have noticed that over at Rick's classic camaro they show a few different linkages and accellerator arms, what u guys sugges and any pics, i have the straight up and down one not the one with the bend in in thanks
tekin is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old Jan 21st, 08, 05:37 AM
Moderator
Kevin
 
KevinW's Avatar
 
Join Date: Jul 2000
Location: Millstone, NJ
Posts: 11,075
Re: Gas pedal problem ( Rod)

Does yours look like this?

http://cgi.ebay.com/ebaymotors/1967-...em360015448046

Kevin


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
KevinW is offline  
post #3 of 18 (permalink) Old Jan 21st, 08, 07:24 AM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: Gas pedal problem ( Rod)

I think we have tried to answer this for you before, but let's try again.

The 67-69 Camaro with a 6 cylinder used a gas pedal arm that only stuck through the firewall mount far enough to get an e-clip on it, and it had an arm higher up (inside the car, on the pedal arm itself) with an eye where the end of the 6 cyl throttle cable mounted.

If you have a gas pedal arm that fits through the firewall with enough of a shaft to attach a V8 style throttle arm, you have either a Camaro V8 gas pedal, or some pedal of the same general style that sort of fits. And if your throttle arm doesn't have the dog leg on it like the one Kevin posted above, or the ones posted multiple times in response to this same question you've asked before, it is not a 67-69 Camaro throttle arm.

You either need to post close up, detailed pictures of what you have, or read and understand the responses to your previous posts on this and get the correct set up. You may just need the throttle arm (if you have the correct gas pedal rod for a V8 1st gen) or you may need the whole assembly for both (if you have some donor assembly from some unknown car that may not have the right positioning to allow it to work in a 1st gen).

Otherwise, you keep asking the same question, and we keep posting pics and telling you to get a V8 1st gen setup....

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
 
post #4 of 18 (permalink) Old Jan 21st, 08, 10:26 AM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Re: Gas pedal problem ( Rod)

ok i will get pics today and thank u very much the only reason i ask this question is that i am confused about the setup as the parts are not listed in classic book and i guess the only way to do it is post some pics thanks guys yes it is a stock virgin 67 camaro
tekin is offline  
post #5 of 18 (permalink) Old Jan 21st, 08, 02:04 PM
Senior Tech
Jon
 
Rodder's Avatar
 
Join Date: Jul 2006
Location: Roswell, GA
Posts: 1,431
Send a message via AIM to Rodder Send a message via Yahoo to Rodder
Re: Gas pedal problem ( Rod)

Quote:
Originally Posted by Eric Kammerer View Post
I think we have tried to answer this for you before, but let's try again.

The 67-69 Camaro with a 6 cylinder used a gas pedal arm that only stuck through the firewall mount far enough to get an e-clip on it, and it had an arm higher up (inside the car, on the pedal arm itself) with an eye where the end of the 6 cyl throttle cable mounted.

If you have a gas pedal arm that fits through the firewall with enough of a shaft to attach a V8 style throttle arm, you have either a Camaro V8 gas pedal, or some pedal of the same general style that sort of fits. And if your throttle arm doesn't have the dog leg on it like the one Kevin posted above, or the ones posted multiple times in response to this same question you've asked before, it is not a 67-69 Camaro throttle arm.
Are you sure about that? I thought the cable throttle pedal was a '69 (6cyl/crossram) thing--I know I've seen 67's 6cyls with a throttle arm linkage, and noted that the throttle arm looked a lot different than my 68 8cyl.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- LS1, T56, Hooker longtubes, Autokraft pan & mounts, GM LS7 clutch, Borla ProXS, Moser/Strange/Wilwood 9", Covans dash, UltraLite IIs, Procar Elites, Vintage Air GEN-IV, AGR 12:1 steering, Addco swaybars, Hydratech hydroboost
Rodder is offline  
post #6 of 18 (permalink) Old Jan 21st, 08, 08:43 PM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: Gas pedal problem ( Rod)

I do not have a 67 AIM here, but the 68 AIM clearly shows L6 cars receiving the same throttle cable assembly as 69.

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
post #7 of 18 (permalink) Old Jan 21st, 08, 09:16 PM
Senior Tech
Pat
 
Join Date: Feb 2006
Location: Nashville,Tn.
Posts: 1,280
Re: Gas pedal problem ( Rod)

My 67 was an original 6cyl car...the original 6cyl pedal rods and linkage is what i am using on the 350 that is in it now. The 67 did not have a throttle cable it has a throttle rod that goes from the pedal assembly directly to the carb...all i did was spin the connector out the throttle rod,which is threaded until it worked on the 350.
67pat is offline  
post #8 of 18 (permalink) Old Jan 21st, 08, 09:17 PM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: Gas pedal problem ( Rod)

Okay, so 67 is different than 68-69...and tekin needs to talk to you about how to get his to line up.

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
post #9 of 18 (permalink) Old Jan 21st, 08, 11:42 PM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Re: Gas pedal problem ( Rod)

yeah but what about the throttle lever

Last edited by tekin; Jan 22nd, 08 at 10:17 PM.
tekin is offline  
post #10 of 18 (permalink) Old Jan 22nd, 08, 01:51 PM
Senior Tech
Pat
 
Join Date: Feb 2006
Location: Nashville,Tn.
Posts: 1,280
Re: Gas pedal problem ( Rod)

Quote:
Originally Posted by tekin View Post
yeah but hat about the throttle lever
???
67pat is offline  
post #11 of 18 (permalink) Old Jan 22nd, 08, 10:20 PM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Re: Gas pedal problem ( Rod)

how do i post pics i can not do it can anyone tell me how thanks
tekin is offline  
post #12 of 18 (permalink) Old Jan 22nd, 08, 10:57 PM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: Gas pedal problem ( Rod)

http://www.67rs-ss.com/pictures/pictures.html

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
post #13 of 18 (permalink) Old Jan 23rd, 08, 10:36 AM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Re: Gas pedal problem ( Rod)

i uploaded them but how do u attach them to this link as i put the URL in and it does not work hmmmmm
tekin is offline  
post #14 of 18 (permalink) Old Jan 23rd, 08, 10:39 AM
Senior Tech
Mark
 
Join Date: Nov 2006
Location: Double Oak, Texas
Posts: 1,031
Re: Gas pedal problem ( Rod)

Quote:
Originally Posted by tekin View Post
i uploaded them but how do u attach them to this link as i put the URL in and it does not work hmmmmm
Just copy and paste the link to the pic in your thread.

Glacier Blue/Dover White 69 SB SS Restoclone.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


99 Trans Am...my toy

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Old Man is offline  
post #15 of 18 (permalink) Old Jan 23rd, 08, 11:53 AM Thread Starter
Senior Tech
Romeo
 
Join Date: Oct 2007
Location: vancouver, b.c.
Posts: 269
Re: Gas pedal problem ( Rod)



tekin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome