Please Help Leaking Coolant - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 2nd, 08, 11:18 AM Thread Starter
 
Join Date: Oct 2003
Posts: 20
Please Help Leaking Coolant

I replaced the hoses that enter the heater core w/ a chrome version. I started the 69 camaro up and I have antifreeze leaking from the bottom of the heater core cover. It doesn't look like it is leaking from the new hose connection. It looks like it is running around the cover on the fire wall of the heater core. What can I do to fix this? Thanks for your help.
WILDWILLY69Z is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 2nd, 08, 11:37 AM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Please Help Leaking Coolant

Sounds like u may have just bent the core outlets slightly lining them up or removing adding the hoses...doesnt take much to get a crack on the core where the tubes go in.
DDid u pull the old hoses off or cut them off? they need to be cut off to advoid issues

Pull the heater core from under the dash, get the leak fixed and put back.
When u get the leak fixed, make sure u have the tubes exactly so they will slide striaght thru the firewall with out tweaking

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #3 of 3 (permalink) Old Feb 2nd, 08, 02:39 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Please Help Leaking Coolant

I'm with Steps on this one, it happened to me, too. Never a problem with my old core, til I had the audacity to replace the heater hoses.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome