Drove it today...not impressed - Team Camaro Tech
Engine General Engine Discussion.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 32 (permalink) Old Apr 5th, 08, 06:51 PM Thread Starter
Senior Tech
Craig
 
Brackneyc's Avatar
 
Join Date: Jan 2005
Location: Quad Cities, IL
Posts: 3,910
Drove it today...not impressed

Well,. the new cam is in and I got to drive it today. It seems very unresponsive and sluggish. I put in a new Lunati Voodoo cam, had the heads done and added a new Carburetor. I ended up putting on the old carb because when you put it in drive, the engine would die. With the old Edelbrock, it will atleast stay running, but still has huge rpm drop when put in gear. I don't know if it the timing, the carb or just what it is. The tranny is leaking and the speedo stopped working. At idle it sounds amazing, and revs smoothly while in park. It seems ok driving, but a quick hit to the pedal, and it basically falls on its face.

Also, when I turn the lights on, both turn signals indicators glow green...never did that before. The car has basically sat for a full year, and I know stuff happens.

Any ideas for the lights or the motor? I'm taking it in to have the transmission looked at. I hope I don't have to have someone else tune it for me, but I may end up doing that too.

Craig


------------------------------------------------------------------------------
Now you will see that evil will triumph, because good is dumb.
-Dark Helmet

1967 Camaro
1965 Mustang
2007 Mustang
Brackneyc is offline  
Sponsored Links
Advertisement
 
post #2 of 32 (permalink) Old Apr 5th, 08, 06:57 PM
Senior Tech
David
 
Join Date: Oct 2007
Location: Rainsville, Alabama
Posts: 4,274
Re: Drove it today...not impressed

Quote
"Any ideas for the lights "

Could be either a bad ground or the flasher relay.Most common is the ground.

"All I need is a fast machine". Steve McQueen
My Machine: 1969 Pro Street Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

468 CID 661 Horsepower
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Turbo 400
33"x19.50" Mickey Thompsons

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1969ProStreetCamaro is offline  
post #3 of 32 (permalink) Old Apr 5th, 08, 07:26 PM
Senior Tech
john
 
wagonman's Avatar
 
Join Date: Oct 2004
Location: northern california
Posts: 2,796
Re: Drove it today...not impressed

sounds like retarted timimg......

put a timing light on it and see where your at.

Remember,I'm not making this stuff up!

1969 rs/ss 396 350hp/4spd conv a/c,pw,ps,foldown
1968 Z/28 crossram- j/l8 conv pw,ps,foldown
1963 nova ss 350/4spd conv a/c,ps,pt
1963 nova 400 4dr 6cyl/700r4 a/c
2006 GT/5spd mustang conv
wagonman is offline  
 
post #4 of 32 (permalink) Old Apr 5th, 08, 07:28 PM Thread Starter
Senior Tech
Craig
 
Brackneyc's Avatar
 
Join Date: Jan 2005
Location: Quad Cities, IL
Posts: 3,910
Re: Drove it today...not impressed

Quote:
Originally Posted by wagonman View Post
sounds like retarted timimg......

put a timing light on it and see where your at.

Would that also have caused some backfiring through the carb? It did that a few times, but didn't do it the last few times I started it.

Craig


------------------------------------------------------------------------------
Now you will see that evil will triumph, because good is dumb.
-Dark Helmet

1967 Camaro
1965 Mustang
2007 Mustang
Brackneyc is offline  
post #5 of 32 (permalink) Old Apr 5th, 08, 07:33 PM
Banned
Ron
 
Badbird's Avatar
 
Join Date: Jul 2005
Location: Dearborn Heights, MI
Posts: 3,176
Re: Drove it today...not impressed

Sounds retarded to me too!
Badbird is offline  
post #6 of 32 (permalink) Old Apr 5th, 08, 07:48 PM
Gold Lifetime Member
Don
 
Join Date: Jan 2005
Location: 2 Dog Town in West Texas
Posts: 11,154
Re: Drove it today...not impressed

Craig, what are you working on? Motor, cam , carb etc?

Don
TC # 349
Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E Owner since Dec 1968

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zdld17 is offline  
post #7 of 32 (permalink) Old Apr 5th, 08, 09:39 PM Thread Starter
Senior Tech
Craig
 
Brackneyc's Avatar
 
Join Date: Jan 2005
Location: Quad Cities, IL
Posts: 3,910
Re: Drove it today...not impressed

350, Edelbrock 600 268 Lunatic cam

Craig


------------------------------------------------------------------------------
Now you will see that evil will triumph, because good is dumb.
-Dark Helmet

1967 Camaro
1965 Mustang
2007 Mustang
Brackneyc is offline  
post #8 of 32 (permalink) Old Apr 5th, 08, 10:26 PM
Team Member
Steve
 
Join Date: Nov 2005
Location: East SF Bay Area
Posts: 1,716
Garage
Re: Drove it today...not impressed

You got a problem somewhere. What's the timing set at?

I have a 350, 650 dp, holley, 276 voodoo with RPM heads at 10:1 compression.
That combo gets it done.

Steve
1968 that started life and a 6 banger with a PG. Now it's a 350 with a TKO600, Moser 12 bolt, Speedtech LCA/UCA, ATS Tall Spindles, Hotchkis Springs, Forgeline ZX3P, C5 (Kore3) brakes with other cool stuff from Ron Davis, Vintage Air and soon to be Terminator EFI.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
eville is online now  
post #9 of 32 (permalink) Old Apr 5th, 08, 10:28 PM
Gold Lifetime Member
Lane
 
Join Date: Aug 2004
Location: Below Sea Level, La
Posts: 507
Re: Drove it today...not impressed

I'm no expert here but could you have blown the power valve in the first carb?


Joe

*********************************
69' Camaro X44 Base Coupe - 1\4 - 12.79
383 Stroker\700R4\Vigilante\12 Bolt Eaton Posi 3:55
QA1; Hotchkis; Vintage Air; IROC Steering Box
Owned and operated for over 20 years....................

04' CTS-V - Daily Driver -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-

LS6, Headers, Cam, Corsa exhaust, Electric cutouts.
sixtynine is offline  
post #10 of 32 (permalink) Old Apr 5th, 08, 11:09 PM Thread Starter
Senior Tech
Craig
 
Brackneyc's Avatar
 
Join Date: Jan 2005
Location: Quad Cities, IL
Posts: 3,910
Re: Drove it today...not impressed

My understqnding is that the new Holleys have a check ball to prevent blown power valves. Any truth to this?

Craig


------------------------------------------------------------------------------
Now you will see that evil will triumph, because good is dumb.
-Dark Helmet

1967 Camaro
1965 Mustang
2007 Mustang
Brackneyc is offline  
post #11 of 32 (permalink) Old Apr 5th, 08, 11:32 PM
6D9
Senior Tech
Ron
 
Join Date: Jul 2003
Location: stockton,ca
Posts: 2,358
Re: Drove it today...not impressed

Yep....gotta be timing. Set her somewhere between 16-18 initail and 34-36 total. Should run sweet. How much compression does your 350 have??

69 Camaro
491/AFR 315'S/Straub hyd roller
TH400/GV OD
9" 3.50
6D9 is offline  
post #12 of 32 (permalink) Old Apr 6th, 08, 01:45 AM
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: Drove it today...not impressed

Is it backfiring, or spitting gas up thru the carb?

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
post #13 of 32 (permalink) Old Apr 6th, 08, 01:51 AM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Re: Drove it today...not impressed

set the initial timing to about 18 degrees, and put the vacuum advance to full manifold vacuum.
then come back and tell us what it does.

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
post #14 of 32 (permalink) Old Apr 6th, 08, 05:55 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Drove it today...not impressed

The guys got it.

Advance the timing some more.

Both signal indicators glowing with headlights on = bad ground to gauge cluster.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #15 of 32 (permalink) Old Apr 6th, 08, 07:16 AM
 
Join Date: Apr 2000
Posts: 21,341
Red face Re: Drove it today...not impressed

What keyway did you put the timing set at??

Maybe off 4 degrees one way or the other??

Know all about this..

pdq67



pdq67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome