no fire - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Apr 5th, 08, 10:17 PM Thread Starter
 
Join Date: Jan 2006
Posts: 387
no fire

I recently put in a petronix ignition conversion kit and coil. My 396 ran great for a couple of months. Then, depression set in. At first it would try to start while the starter was turning the die when the key relaxed to on. Now its not even trying to start. Got fuel. Got battery juice. Wires all connected. Timing was OK recently and the distributor is still on the mark. Caps on tight. Help!!
68fan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Apr 5th, 08, 10:29 PM
 
Join Date: Nov 2007
Posts: 106
Re: no fire

It sounds like your ignition ground may not be good enough, or you new box went bad. Are you getting spark at the plug?
Travis1 is offline  
post #3 of 5 (permalink) Old Apr 5th, 08, 10:35 PM Thread Starter
 
Join Date: Jan 2006
Posts: 387
Re: no fire

I guess I could hook up my timing light to see if I'm getting spark to the plugs. When you say the "new box" might have gone bad, do you mean the coil? thanks
68fan is offline  
 
post #4 of 5 (permalink) Old Apr 6th, 08, 02:11 PM Thread Starter
 
Join Date: Jan 2006
Posts: 387
Re: no fire

Problem solved. Must have had faulty connection to coil. Reconnected and now runs like a top!
68fan is offline  
post #5 of 5 (permalink) Old Apr 6th, 08, 08:50 PM
 
Join Date: Nov 2007
Posts: 106
Re: no fire

There ya go. Glad you get it goin.
Travis1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome