BRP LS1 engine mounts and rack and pinon - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 13th, 09, 11:20 AM Thread Starter
justin
 
Join Date: Jul 2009
Location: califorina
Posts: 1
BRP LS1 engine mounts and rack and pinon

I have a 68 camaro that i put a ls1 out of a 2001 camaro in and i have a unisteer rack and pinon alreafy in it. The problem is with the new motor mounts the u joint for the steering shaft wont clear. has anybody had this problem before and how did you fix it. i woulod reaaly like to keep the rack and pinon.
jmhamilton68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome