Header Issue - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 2nd, 10, 01:06 PM Thread Starter
Senior Tech
Chris
 
Join Date: May 2007
Location: Toronto
Posts: 243
Header Issue

So I'm having a crazy hard time finding header's for my car.
It has ported L98 head's on it, and everything I find for our car's says not for angle plug head's, or is circle port. [L98 being D port].
I'm currently just running the stock manifolds on the car and surprisingly it doesn't seem to leak.. so would any rectangle port headers work?.. are rectangle and D port the same thing?
SunnyZ28 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 2nd, 10, 05:12 PM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,030
Re: Header Issue

I had same issue with brodix heads but i found a good set
http://www.summitracing.com/parts/ED...3/?image=large


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #3 of 4 (permalink) Old Mar 2nd, 10, 05:18 PM
Tech Team
Alex
 
Join Date: Jul 2009
Location: Dallas, TX
Posts: 87
Re: Header Issue

Doug's D368 worked great on my Pro 1's

'69 Z28: X33 / 02B / non-matching 302 / Dart 200cc pro 1 platinum heads / Crower solid roller / matching M21 / matching BU axle / 4:11 ring and pinion
69duskblueX33 is offline  
 
post #4 of 4 (permalink) Old Mar 2nd, 10, 10:25 PM
Senior Tech
Andy
 
Join Date: Jul 2005
Location: Northeast,GA
Posts: 1,398
Send a message via AIM to 67SS&99SS
Re: Header Issue

I run D368s on my 67 with L-98 Style D-port AFR 195 heads with angle plugs with no issues.

1967 Camaro SS: 406 sbc, 522hp/514 ft lbs, Doug's 1 3/4" headers, M20, posi, 3.73's, vintage air gen IV, IROC steering box, Comp Eng. weld-in sfc's & traction bars, chrome US Mags

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67SS&99SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome