Quadrajet troubleshooting - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Apr 11th, 10, 06:37 AM Thread Starter
Tech Team
jp
 
Join Date: Jun 2007
Location: indiana
Posts: 59
Quadrajet troubleshooting

I finally got my car out for the first road test. It is a total original 68 fresh rebuilt 350. Got all the bugs worked out of the stove for the choke and starts up accellerates good and runs great. My problem is when I took it on the road and got on it a little, to feel some power, it just did not have it. It was like the secondaries were not opening. I got it home to see if they were still opening and they were. When I pull the throttle back and the seconaries open the top butterfies just flutter. I did run it with the stock (horned) air cleaner on. Is it possiable it is not getting enough air or should I look elsewhere.
Thanks
shovelluv is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 12th, 10, 03:22 PM
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: Quadrajet troubleshooting

I sounds like the secondary air-valve spring is set a little too tight, which is preventing the secondary air-valve (the top secondary butterflies) from opening. There is an adjustment on the driverís side of the carburetor that you can use to adjust the spring tension. Itís usually adjusted with a small screwdriver and held in place with an allen screw. Adjust in small increments Ė it doesnít take much of an adjustment to make a big difference. Iíd try loosening the setting about a 1/4 turn and see if that makes a difference.

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome