Anti-freeze.......again - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Mar 20th, 11, 06:35 AM Thread Starter
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,431
Garage
Send a message via MSN to DOUG G
Anti-freeze.......again

Looks like I popped a gasket or head bolts came loose

anti-freeze spitting out tail pipe....looked in radiator and levels down 1"-2"

Gotta pull motor again This SUCKS !!!!!

Thinking it may be time to look into new one ?

Really liking these LSX motors now. Guy had one in a gutted 65?Mustang that was set-up for road course/cones, and on regular radials spinning was running 10.9's @ 130 (LS7 cammed & N/A)
Buddy down the street with an 84? Monte 80K mile LS1 Corvette motor and a H2 magnacharger <?> was 11.3's in the 120's

Gotta dig deeper yet....

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Mar 20th, 11, 06:44 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,029
Re: anti-freeze.......again

i bet you used regular tap water coolant mix???
Alway use distilled water !
also once you put it all together before you NEED to do a retorque of all the bolts after a few heat cycles.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #3 of 6 (permalink) Old Mar 20th, 11, 06:52 AM
Gold Lifetime Member
Dave C
 
Join Date: Jan 2007
Location: maryland
Posts: 5,495
Send a message via AIM to Pro-Street69Camaro468 Send a message via Yahoo to Pro-Street69Camaro468
Re: Anti-freeze.......again

Sorry to hear this man what a way to start the season....Well at least it will be new.....

PRO.ST69orange

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Pro-Street69Camaro468 is offline  
 
post #4 of 6 (permalink) Old Mar 20th, 11, 07:15 AM Thread Starter
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,431
Garage
Send a message via MSN to DOUG G
Re: Anti-freeze.......again

Gonna do bolts first and see what happens....

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
post #5 of 6 (permalink) Old Mar 20th, 11, 05:45 PM Thread Starter
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,431
Garage
Send a message via MSN to DOUG G
Re: Anti-freeze.......again

OK...looks like the balancer took a dump (cheap POS) and no water in oil
Looks like I'll re-torque the heads and test ?

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
post #6 of 6 (permalink) Old Mar 20th, 11, 06:54 PM
Gold Lifetime Member
BILL
 
SPARKY69's Avatar
 
Join Date: Oct 2007
Location: HENDERSONVILLE N.C.
Posts: 9,352
Re: Anti-freeze.......again

breakdowns suck..aggrivating..
but thats hotrodding!!
i love every drop of sweat because of all the smiles they turn into!

BILL D.
JOHN 3:16
SEMPER FI
if you have a bbc in your 1st gen 67-69 camaro click on the link below and enjoy the veiw and post yours up!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

if you have an all original 1st gen camaro 67-69 click on the link below and enjoy the veiw and post your up!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SPARKY69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome