Squicking noise on idle - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Apr 9th, 11, 08:52 PM Thread Starter
Gold Lifetime Member
Tim
 
trhack0214's Avatar
 
Join Date: Apr 2011
Location: Alabama
Posts: 54
Send a message via Yahoo to trhack0214
Squicking noise on idle

I have posted before about a slight tapping noise, but now I am wondering why im hearing this squicking sound while it is idling. I have a brand new comp cam .501 lift on it. Could it be my mounts are loose and its actually shacking the engine? i will try and post up a sound clip of it tomorrow.
trhack0214 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Apr 9th, 11, 08:56 PM
Senior Tech
Wes
 
Join Date: Dec 2003
Location: Leander, TX
Posts: 2,762
Re: Squicking noise on idle

For engine squeeking noises, I'd look firts at the belts; PS, AC, Alternator/Water Pump. Spray some WD-40 on the belt(s) at idle and if the noise goes away, get a new belt(s).

Could be bearings going south on the above components as well.
Straight-line-69 is offline  
post #3 of 6 (permalink) Old Apr 9th, 11, 09:04 PM Thread Starter
Gold Lifetime Member
Tim
 
trhack0214's Avatar
 
Join Date: Apr 2011
Location: Alabama
Posts: 54
Send a message via Yahoo to trhack0214
Re: Squicking noise on idle

Ok i will try first the most easy method and do WD-40. if that doesnt work onto other items
trhack0214 is offline  
 
post #4 of 6 (permalink) Old Apr 10th, 11, 07:56 PM
Senior Tech
darrell
 
Join Date: Feb 2011
Location: texas
Posts: 1,202
Re: Squicking noise on idle

also make sure brackets are tight and bell housing
97Z4C is offline  
post #5 of 6 (permalink) Old Apr 10th, 11, 10:33 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: Squicking noise on idle

Dont put WD40 stuff on belts...simply dribbling a little water on a noisy belt will shut it up...telling u which belt..if it is a belt.

A mechanics stethoscope...Or long screwdriver to the ear on things like the alternator will ID the source and if a Alternaer breaing.

A std Doctors stethoscope held in the engine compartmenr will quicly ID the direction the noise is in.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #6 of 6 (permalink) Old Apr 11th, 11, 02:10 PM
Senior Tech
Tom
 
Join Date: Mar 2006
Location: Joplin
Posts: 1,377
Re: Squicking noise on idle

I found a squeaking noise at idle to be a loose tansmission mount.

But you'd swear it was coming from the front of the engine.

71 Camaro 355 NA
11.1650 @ 119.30
1.5028 60'
hhott71 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome