secondary shaft spring keeps popping off - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jun 14th, 14, 12:51 PM Thread Starter
Premium Member
Gordon
 
gordr's Avatar
 
Join Date: Jun 2009
Location: Kelowna, BC, Canada
Posts: 1,095
secondary shaft spring keeps popping off

I've got a 7037211 Quadrajet carb and the outer secondary shaft spring pops off once in a while and I've got to do a hard resetting in of that spring. Yesterday it popped off again and taking a good look at it I can see that my secondary's throttle shaft cut-groove in it is perpendicular up and down when the shaft plates are closed. Doing an image search on the web shows me that all the other ones I came up with have that cut-groove slit in line with the secondary throttle plates, side-to-side when the plates are closed. So, that's why I'm forcing my spring in there as it's going around too far due to the perpendicular cut-groove slit in mine. Attached is a pic to show, the secondary throttle plates are closed but the slit is almost perpendicular. Maybe all along I've had the wrong shaft? I can't see anywhere where I could adjust that cut-groove slit to put in the position that's best.
Attached Thumbnails
Click image for larger version

Name:	IMG_0884[1].jpg
Views:	39
Size:	66.3 KB
ID:	76145  

67 Plain Jane being assembled with 427, 4 spd Muncie, 12 bolt rear with Mosers, 4 wheel discs
gordr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jun 15th, 14, 08:46 AM
Senior Tech
Mark
 
Join Date: Sep 1998
Location: Ontario, Canada
Posts: 2,009
Garage
Re: secondary shaft spring keeps popping off

Get a nylon bushing in the hole or fill the gap with JB Weld (reg) not quick dry. Or a nylon tube jammed into the hole then trim both sides.

Mark 70 Z28 M22 3.73 Z21 Z87 - Lunati 20120121 Roller Cam

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
COPO is offline  
post #3 of 4 (permalink) Old Jun 15th, 14, 09:59 AM Thread Starter
Premium Member
Gordon
 
gordr's Avatar
 
Join Date: Jun 2009
Location: Kelowna, BC, Canada
Posts: 1,095
Re: secondary shaft spring keeps popping off

It's not the hole itself as it's a snug fit into the hole.... WHY is my cut-groove slit almost up and down perpendicular/vertical whereas most of the others I see are from side to side horizontally. HOW can I adjust the cut-groove slit to the proper side to side position horizontally? from the looks of it it's a solid secondary shaft....I'm hoping somehow I can adjust that cut-groove slit to horizontal. Anyone have any ideas on that?

67 Plain Jane being assembled with 427, 4 spd Muncie, 12 bolt rear with Mosers, 4 wheel discs
gordr is offline  
 
post #4 of 4 (permalink) Old Jun 15th, 14, 02:25 PM Thread Starter
Premium Member
Gordon
 
gordr's Avatar
 
Join Date: Jun 2009
Location: Kelowna, BC, Canada
Posts: 1,095
Re: secondary shaft spring keeps popping off

I found the cut-groove slit to be in the correct position for that setup, not sure why mine's different. Someone sent me a pic, below, of the proper way to have the spring oriented in there. Used heavy duty grips and that to bend the spring winding inwards to get it into good position, here's hoping it lasts a while.....
Attached Thumbnails
Click image for larger version

Name:	Quadrajet secondary shaft spring setup 67 Camaro 396.jpg
Views:	28
Size:	77.2 KB
ID:	76194  

67 Plain Jane being assembled with 427, 4 spd Muncie, 12 bolt rear with Mosers, 4 wheel discs
gordr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome