Misc engine install questions - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 23rd, 14, 10:35 AM Thread Starter
Gold Lifetime Member
Randy
 
Join Date: Jun 2012
Location: Illinois
Posts: 380
Misc engine install questions

Hey guys, been out of action for more than a year due to health issues but lately been feeling well enough to get greasy again. Pulled my old 350 sbc out of my standard 1969 camaro with m20 tranny. Unbolted the bellhousing from the tranny and only pulled the engine.

Questions #1) I noticed that when I look at the tranny from the front of the car it appears to be tilted to the driver's side. Meaning the mounting bolts on the passenger side seem to be slightly higher than the ones on the driver's side. I looked underneath and it appears to be mounted correctly, is this normal?

Questione #2) I need a new flywheel and looking for recommendations. I have a built 383 stroker - 430HP, 400+ftlbs torque, manual M20 tranny. Internally balanced. Do I need anything special or will a standard 350 flywheel be fine?

Question #3) engine and engine frame mounts -replacing all the mounts, frame and engine mounts. Wanting to get the poly mounts, any recommendations? Also heard that the 69 frame mounts are "special" any issues there?


Thanks a ton guys!


Randy

1969 Cheverolet Camaro - Pro Touring
2018 Dodge Challenger R/T ScatPack 392 Shaker Hood Hemi
2016 BMW R1200rs
1976 Honda CB550 - I restored
il_randyb is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 23rd, 14, 06:56 PM
Senior Tech
Mike
 
Join Date: Nov 2007
Location: Inverness, IL
Posts: 143
Re: Misc engine install questions

Quote:
Originally Posted by il_randyb View Post
Hey guys, been out of action for more than a year due to health issues but lately been feeling well enough to get greasy again. Pulled my old 350 sbc out of my standard 1969 camaro with m20 tranny. Unbolted the bellhousing from the tranny and only pulled the engine.

Questions #1) I noticed that when I look at the tranny from the front of the car it appears to be tilted to the driver's side. Meaning the mounting bolts on the passenger side seem to be slightly higher than the ones on the driver's side. I looked underneath and it appears to be mounted correctly, is this normal?

Questione #2) I need a new flywheel and looking for recommendations. I have a built 383 stroker - 430HP, 400+ftlbs torque, manual M20 tranny. Internally balanced. Do I need anything special or will a standard 350 flywheel be fine?


Question #3) engine and engine frame mounts -replacing all the mounts, frame and engine mounts. Wanting to get the poly mounts, any recommendations? Also heard that the 69 frame mounts are "special" any issues there?


Thanks a ton guys!


Randy
1.That is normal. The transmission is sitting on the rubber mounted tail shaft bushing. The bell housing will tie it together when you bolt it to the engine.

2.You can use a standard 350 flywheel but you need to make sure it is zero balance. You can also buy a zero balance billet flywheel. Was the engine built with a flywheel? If so, that is the one you want to use if you don't know if it was balanced as an assembly.

3. There is a short and tall motor mount. The short is 1.5 inches from the block mounting surface to the center of the bolt hole. The tall is 2 1/8 inches. I am not sure about the frame stands. Someone else might reply with that info.

Good luck with your build
Mike
MJK-4 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome