Failed bronze tip fuel pump pushrods - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Jul 31st, 14, 05:33 PM Thread Starter
Senior Tech
 
Join Date: Feb 2007
Location: Southern California
Posts: 153
Failed bronze tip fuel pump pushrods

From time to time, over the past couple of years or so, folks have been posting threads on some of the Forums about failed bronze tip fuel pump pushrods. There has of course been some discussion about all that, but no real wind-up as to what is actually going on here.

Since there has not been a solution, some folks have switched to composite fuel pump pushrods in an effort to get out from under this problem. However, that may not be the best choice either, since there have been reports of composite fuel pump pushrods failing, as well as well known failures of composite distributor gears, inside running engines. And that can leave you with quite a task to clean all the broken pieces out of the engine, not to mention having a running failure when you least expect it. So, I don't believe composite engine internal components are a good idea in our traditional SB and BBC's, because failures of that nature indicate an unacceptable margin of safety.

I think it is much better to get to the root cause of what the problem may be with the metallic parts in question. Because bronze fuel pump pushrod tips and bronze distributor gears won't generally ever break on you, in a running engine, even if they may have some wear issues. Bronze parts such as those, are softer material and are expected to wear, thus preventing wear on your steel cam. They are maintenance items, much like solid roller lifters. You can't expect to install them and permanently forget them. At the very least, you should periodically inspect them to see how things are going.

In any case, I think it is about time to do a failure analysis of bronze tip fuel pump pushrods to get to the bottom of the failures some folks are experiencing. To accomplish this, I'm in the process of gathering as much information as I can about this issue.

So, if you'd like to be part of this failure analysis, please share the details about your bronze tip fuel pump pushrod failure, by answering the questions below:

NOTE: Just as important to this overall failure analysis of what did NOT work, is what DID work. So, if you've run a bronze tip fuel pump pushrod, and have had no issue with it, please answer the questions below as well.

1. Did your bronze tip fuel pump pushrod fail on you, or has it been fine?

2. If your bronze tip fuel pump pushrod failed on you, what brand was it?

3. If you experienced a failure, would you consider it excessive wear, or did the bronze tip mushroom to the point that you could not get it out of the block?

4. How many miles did you get out of it, or have gotten out of it so far, if it was primarily a street car?

5.How many passes did you get out of it, or have gotten out of it so far, if it was primarily a drag car?

6. What percentage of the time was this engine operated on the street, and/or what percentage of the time was this engine operated on the track?

7. What rpm did this engine most commonly see?

8. What is the psi rating of the mechanical fuel pump used with this pushrod. The psi is determined by how stiff the diaphragm spring is, which in turn, determines the load applied on the bronze tip.

9. What specific oil or oils, and what viscosity version of that oil or oils, did you use or are using with this pushrod?

10. Did you use any aftermarket oil additives in the oil used with this pushrod?

11. I'd like to get my hands on as many failed pushrods as I can for evaluation. So, would you be willing to send me your failed bronze tip fuel pump pushrod for that purpose? If you really want to keep the pushrod, I'd be happy to return it to you after the evaluation.

12. If you have any additional information on failed composite fuel pump pushrods, please share that as well.

After gathering as much information as possible on the bronze tip pushrods, including physical evaluation of failed parts, I'll post the results of the analysis. And hopefully, we'll have a workable go-forward plan at that time.

Thanks for any information you are willing to share.

540 RAT

Mechanical Engineer

U.S. Patent Holder

Member SAE (Society of Automotive Engineers)

Member ASME (American Society of Mechanical Engineers)

To see my entire 130+ motor oil “Wear Protection Ranking List”, along with additional motor oil tech FACTS (with over 40,000 “views” worldwide), here’s a link:

http://540ratblog.wordpress.com/
540 RAT is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Jul 31st, 14, 05:54 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: Failed bronze tip fuel pump pushrods

I've heard nothing but good things about this pushrod:

http://www.summitracing.com/parts/hrs-94475/overview/

Thoughts?

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
post #3 of 8 (permalink) Old Aug 1st, 14, 08:01 AM
Senior Tech
Al
 
Join Date: Nov 2002
Location: Vancouver, USA
Posts: 10,511
Re: Failed bronze tip fuel pump pushrods

Quote:
Originally Posted by ZZ430DropTop67RS View Post
I've heard nothing but good things about this pushrod:

http://www.summitracing.com/parts/hrs-94475/overview/

Thoughts?
That's the one I'm using on a steel cam, Don, but only since July 1st of this year. Still pumping fuel! Prior to that I was using the original steel pushrod out of my old 307 for 12,000 miles w/o issue. I only swapped to the composite for peace of mind. Have also been using Comp's composite dist gear for about 10,000 miles. It is showing some wear, but not enough in my opinion to replace it. Stock oil pump.

My engine builder mentioned that he has been using a ceramic tipped fuel pump rod on his circle track engines with good success, but I don't have any info beyond that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BPOS is offline  
 
post #4 of 8 (permalink) Old Aug 1st, 14, 08:12 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,486
Garage
Re: Failed bronze tip fuel pump pushrods

The question is will 540 RAT respond to anything folks post in this thread or will he do his usual post and disappear never addressing the questions provoked by his postings?

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #5 of 8 (permalink) Old Aug 1st, 14, 12:53 PM Thread Starter
Senior Tech
 
Join Date: Feb 2007
Location: Southern California
Posts: 153
Re: Failed bronze tip fuel pump pushrods

Quote:
Originally Posted by DjD View Post
The question is will 540 RAT respond to anything folks post in this thread or will he do his usual post and disappear never addressing the questions provoked by his postings?
I'm still waiting for input on bronze tip fuel pump pushrod failures or successes, which as stated is the whole point of this thread. But, I see that rather than making a meaningful contribution to the discussion, you just want to make snarky little comments. That is not helpful at all.

I rarely post anything on this Forum anymore because I don't typically get much usable info back, just as I'm seeing this time. I keep hoping things will improve, which is why I tried posting this one here. But, when I do post something, it is usually a stand alone deal, where I'm just sharing info. It's an FYI kind of thing. So, there was no overwhelming reason to check back on any discussion that may come out of it. Plus, I don't have a ton of time to sit on the Internet, which is another reason why I usually don't come back to see what is going on with the discussions.

On occasion when I have checked back in, there is probably more arguing than there is questions or an exchange of information. And I simply don't have time for arguing back and forth.

But, I'm still hoping to get some usable information this time around to help with the failure investigation. Though so far, things look a bit disappointing.

540 RAT
540 RAT is offline  
post #6 of 8 (permalink) Old Aug 1st, 14, 01:17 PM
Senior Tech
Al
 
Join Date: Nov 2002
Location: Vancouver, USA
Posts: 10,511
Re: Failed bronze tip fuel pump pushrods

Quote:
Originally Posted by 540 RAT View Post
However, that may not be the best choice either, since there have been reports of composite fuel pump pushrods failing,..... So, I don't believe composite engine internal components are a good idea in our traditional SB and BBC's, because failures of that nature indicate an unacceptable margin of safety.
Name just about any internal part ever put in a SBC or BBC and I can probably show you a "report" of that part failing. Using that logic we probably shouldn't even start these things.

Quote:
Originally Posted by 540 RAT View Post
Because bronze fuel pump pushrod tips and bronze distributor gears won't generally ever break on you
If you consider a "partially stripped' bronze dist gear breakage there's a thread just below this one that outlines that problem in a 2,000 mile engine https://www.camaros.net/forums/showthread.php?t=294442


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BPOS is offline  
post #7 of 8 (permalink) Old Aug 1st, 14, 01:31 PM
Banned
Chet
 
Join Date: Apr 2014
Location: Oakland County
Posts: 1,353
Re: Failed bronze tip fuel pump pushrods

Quote:
Originally Posted by 540 RAT View Post
I'm still waiting for input on bronze tip fuel pump pushrod failures or successes, which as stated is the whole point of this thread. But, I see that rather than making a meaningful contribution to the discussion, you just want to make snarky little comments. That is not helpful at all.

I rarely post anything on this Forum anymore because I don't typically get much usable info back, just as I'm seeing this time. I keep hoping things will improve, which is why I tried posting this one here. But, when I do post something, it is usually a stand alone deal, where I'm just sharing info. It's an FYI kind of thing. So, there was no overwhelming reason to check back on any discussion that may come out of it. Plus, I don't have a ton of time to sit on the Internet, which is another reason why I usually don't come back to see what is going on with the discussions.

On occasion when I have checked back in, there is probably more arguing than there is questions or an exchange of information. And I simply don't have time for arguing back and forth.

But, I'm still hoping to get some usable information this time around to help with the failure investigation. Though so far, things look a bit disappointing.

540 RAT
Gosh. That's terrible. Yes, it must take a lot of time flooding all enthusiast forums with the same regurgitated "scientific data" like you are some kinid of expert like you did on your infamous oil threads. Care to explain exactly just who you are and what makes you think we are asking for another "investigation"? Nobody took your oil thread seriously.

I don't agree with DjD often but I do on his post about your behavior.
onefiness is offline  
post #8 of 8 (permalink) Old Aug 1st, 14, 04:42 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: Failed bronze tip fuel pump pushrods

Quote:
Originally Posted by BPOS View Post
That's the one I'm using on a steel cam, Don, but only since July 1st of this year. Still pumping fuel! Prior to that I was using the original steel pushrod out of my old 307 for 12,000 miles w/o issue. I only swapped to the composite for peace of mind. Have also been using Comp's composite dist gear for about 10,000 miles. It is showing some wear, but not enough in my opinion to replace it. Stock oil pump.

My engine builder mentioned that he has been using a ceramic tipped fuel pump rod on his circle track engines with good success, but I don't have any info beyond that.
Thanks Al for the feedback.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome