383 breakin - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Nov 2nd, 14, 10:07 PM Thread Starter
Senior Tech
Brian
 
Join Date: Dec 2012
Location: Maryland
Posts: 104
383 breakin

I've got somewhat limited fabrication skills so I'm pretty proud of this run stand I made. I intend to pull the 454 out of my '69 and build something larger and break it in on this stand too. Meanwhile I did a 383 for my truck and broke it in today on the stand. Nothing wild but had to use a carb setup to break it in since it's for a Vortec application I wasn't doing that injection on a run stand just to break in the engine. Turns out I might be selling the truck but still have this new engine sitting around. It ran great, no leaks, set base timing at 14 and all in at 34. I was surprised how well the 770 Street Avenger ran out of the box. A set of headers would help its final configuration as well.

I took a few pics and videos today too. Now I'm looking forward to that community association letter!













https://www.youtube.com/watch?v=RVV6u5Ogp2s

https://www.youtube.com/watch?v=KyYV3ng9Ono
BrianS is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Nov 2nd, 14, 10:38 PM
Gold Lifetime Member
Steve
 
foreverlookin's Avatar
 
Join Date: Oct 2002
Location: Pflugerville, Texas
Posts: 1,757
Garage
Re: 383 breakin

That looks awesome.....sounds like it works good to!

Steve
The best laid plans are those not made (mine)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
foreverlookin is offline  
post #3 of 3 (permalink) Old Nov 3rd, 14, 06:48 AM
Gold Lifetime Member
Jim
 
Join Date: Nov 2006
Location: Maine coast
Posts: 1,290
Re: 383 breakin

Nice set up.
I thought I read somewhere that the electric fuel pumps had to be mounted vertically, although when I think about it, not sure that requirement makes sense.

Jim

Jim
Hanging on the Maine Coast...moved back North

1969 RS/SS, 383, 4spd, 373s, 12bolt, FatMat, Vintage Air - Super Red, and it's my first Camaro.
Engine pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Radiator pics
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Build album

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lobstah is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome