67 camaro struggles to start - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Nov 9th, 14, 03:22 PM Thread Starter
Brian
 
Join Date: Nov 2014
Location: Florida
Posts: 3
67 camaro struggles to start

Hello, first time user. I've got a 67 camaro with a 350 small block engine. My issue is that the car constantly fights me to start and staying running. Most of the time it takes me at least five to ten minutes to get it running and out of the driveway and then it still stalls for the first five minutes that I've driving it until the engine fully warms up. Here's the strange thing, when I connect jumper cables to the battery and try to start it, it starts right up with no problem. Is it possible that my issue is as simple as replacing a dying battery?
Blamber8358 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Nov 9th, 14, 03:26 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 67 camaro struggles to start

Welcome. If you jump her and it starts - does it run or still stall?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #3 of 7 (permalink) Old Nov 9th, 14, 03:30 PM
Senior Tech
Chad
 
cv2065's Avatar
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 1,193
Re: 67 camaro struggles to start

Did you take the battery in to your local auto parts and have it checked under load? If it's good to go, i'd double check your timing...air/fuel mixture...any vacuum leaks...starter/solenoid function/connections....battery terminals for corrosion/connections....starter functionality, to start the ball rolling.

67 Black RS Coupe, 383, M21 & 10 Bolt Posi. Edelbrock E-Tech 170 Heads, 2204 Roller Cam, Air Gap Intake.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cv2065 is offline  
 
post #4 of 7 (permalink) Old Nov 9th, 14, 04:05 PM Thread Starter
Brian
 
Join Date: Nov 2014
Location: Florida
Posts: 3
When I jump it starts up and runs fine. Doesn't stall.
Blamber8358 is offline  
post #5 of 7 (permalink) Old Nov 9th, 14, 05:15 PM
Admin/Super Moderator
Brian
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,509
Garage
Re: 67 camaro struggles to start

As suggested take battery in for a load test or just replace it if it's over 4 years old. Also check your voltage regulator and alternator output for any charging system issues.


Sent from my iPhone using Autoguide


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline  
post #6 of 7 (permalink) Old Nov 10th, 14, 03:53 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,753
Garage
Re: 67 camaro struggles to start

Also, you might consider cleaning the battery posts and clamps, just for grins.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #7 of 7 (permalink) Old Nov 10th, 14, 05:01 PM Thread Starter
Brian
 
Join Date: Nov 2014
Location: Florida
Posts: 3
The battery was 4 years old. I replaced it tonight and started right up just like when I jumped it
Blamber8358 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome