I have a ZIrgo - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 16th, 04, 09:15 AM Thread Starter
Senior Tech
 
Join Date: Mar 2001
Location: Niceville Fl
Posts: 1,070
Post

I just bought the 16' Zirgo electric fan and man is it nice. It came with the adjustable thermostat switch. The only problme is I don't know how to wire it up. I have a wire harness for it with the relay and the fuse but It didn't come with a wire diagram. Do any of you guys know how to wire it? THere is Red and black wire that i will assume are the Hot and the ground. Then there is an orange with a fuse in it, there is also a green with a fuseable link, then there is a yellow and a brown that goes who know's where? All of there wires run to a 40amp relay. THe yellow is not plugged into the relay it is hanging loose but it has been bundeled with the rest of the wires. Any Ideas?

69 Camaro RS, 383ci,10.5-1 AFR 195's ported, Comp 286HR, 4340 forged Crank & Rods, JE Pistons, RPM Airgap, Holley 750 HP carb, 350 turbo w/ shift kit, 3000 Coan, Be cool, caltracs,12bolt 355 eaton posi..Best E.T. 12.22 @ 112

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
69CamaroRacer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 16th, 04, 12:16 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

No diagram? That sucks... a lotta wires for a fan, too. The ground needs to be grounded, that one is easy.

One, probably the red one with the fuse, needs power, easiest would be one of the screw lugs on the horn relay, that will power it all the time, so it will run till the radiator is cool when you shut off the car.

A wire needs to go to the temp switch, which probably has another wire that needs to be grounded as well.

The last one MAY be for a/c, to run the fan when the A/C is on. If you have A/C, run it to the hot wire on the compressor.

did you check their website for a schematic?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 5 (permalink) Old Dec 16th, 04, 01:50 PM Thread Starter
Senior Tech
 
Join Date: Mar 2001
Location: Niceville Fl
Posts: 1,070
Post

I looked on the web site but didn't see much . I do not have AC so that eliminates that. The funny thing is that the red one is not the fused one it is the orange wire. I might have to assume that is the power wire. I might have to call them tomarrow and talk with them. I am really starting from scratch here. My "friend" thought it would be a good idea to cut out the old wire harrness when we removed the old engine and he reassured me that he would help me rewire everything up when it came time. Now i haven't talked to him in 4 months and he does not return my calls so i am stuck trying to figure everything out. I do not have tooo many things to wire just the msd box, alt, distributer, the fan and my wipers. Fun Fun. For the life of me i don't know why he stopped comming around we used to hang out all the time. Oh well

69 Camaro RS, 383ci,10.5-1 AFR 195's ported, Comp 286HR, 4340 forged Crank & Rods, JE Pistons, RPM Airgap, Holley 750 HP carb, 350 turbo w/ shift kit, 3000 Coan, Be cool, caltracs,12bolt 355 eaton posi..Best E.T. 12.22 @ 112

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
69CamaroRacer is offline  
 
post #4 of 5 (permalink) Old Dec 16th, 04, 02:05 PM
Senior Tech
 
Join Date: Dec 2001
Location: Fairfield, CA
Posts: 6,246
Post

Would it look like this?

http://www.zirgo.com/files/ZFSWA.pdf

"For those that will fight for it...FREEDOM ...has a flavor the protected shall never know."
Semper Fi! L/Cpl Edwin L. "Tim" Craft, B Co 3rd AT's, Khe Sanh Combat Base, February, 1968
onovakind67 is offline  
post #5 of 5 (permalink) Old Dec 17th, 04, 10:27 PM
Senior Tech
 
Join Date: Oct 2003
Location: Texas
Posts: 300
Post

69CamaroRacer - I just returned a Zirgo ZFU16S - it had a wicked vibration - the replacement did as well. Got rid of it - onto your wiring: Here's what I did - Used #10 wires from the battery to a relay for negative switched thermostat and manual switch. Used a relay from parts america - terminal 86 is power on from the ignition, termianl 30 is a 12 volt source - battery (#10 wire), terminal 87 is positive power to fan, terminal 85 is to ground, Negative from battery goes to neg on fan. Terminal 85 is wired into two circuts - one for a manual switch to ground the relay, the other is through a thermostatic switch in the intake - when it hit's 195 it grounds an kicks the fans on (it's on a switch as well)....

Rat Touring 1969 Camaro X44 496 Richmond Super T10 Plus 4-Speed 3.55 4 wheel disc
..and sporting all new suspension, wheels, etc etc... take a look...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
nick V is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome