What oil do you guys run - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Feb 8th, 05, 03:18 PM Thread Starter
Senior Tech
Don
 
Join Date: Apr 2001
Location: Redding, CA, 96003
Posts: 1,510
Question

i am currently running casterol 30w in a 355 that is putting out 425+ hp. i want to start running synthetic like royal purple but i dont know which would be best for a daily driven performance engine. thanks james

[ 02-08-2005, 06:31 PM: Message edited by: 1968camaro123 ]

68 Camaro - 540 HP AFR 412 CI, TH350 full manual, 3500 stall, 3.36 yukon gears/axles, 8.2" eaton posi, 17 inch Intro's. Jet black. Hotchkis sways, 3 in drop leafs/springs/bilsteins, G MOD, C5/4th gen brakes. 11.89 @ 119//2.01 60 ft
1968camaro123 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Feb 8th, 05, 05:11 PM
Senior Tech
Brandon
 
Join Date: May 2004
Location: Monroe, NC
Posts: 2,089
Garage
Post

Running 5w 30 Pensoil synthetic.

Brandon J. licence 1NASTY67

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nantooch is offline  
post #3 of 10 (permalink) Old Feb 8th, 05, 05:47 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Post

Mobil 1 10w30 synthetic.

I'll never go back to dino.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
 
post #4 of 10 (permalink) Old Feb 8th, 05, 06:48 PM
Senior Tech
Matt Jones
 
Join Date: Jan 2002
Location: Renton, WA USA
Posts: 2,765
Post

If you don't want to run synthetics, I recommend you use an oil with alot of zinc. Valvoline Racing oil is loaded with zinc...which cannot be found in commonly found oils for modern engines.

The zinc will greatly reduce the wear caused by flat tappet cams with high spring pressures (120lbs+).

Matt Jones
Lead Mechanical Engineer
Art Morrison Ent. Inc.
Silver69Camaro is offline  
post #5 of 10 (permalink) Old Feb 8th, 05, 06:53 PM
 
Join Date: Aug 2001
Posts: 409
Post

I just run whatever because to me oil is oil, mostly valvoline 10-30 . I would have to say from what Ive heard mobile1 is the best.
nitrous383 is offline  
post #6 of 10 (permalink) Old Feb 9th, 05, 11:37 AM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,405
Garage
Send a message via MSN to DOUG G
Post

straight 40W Valvoline. tore heads off for a swap and only a little discolored but otherwise looks like just came form the shop.

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
post #7 of 10 (permalink) Old Feb 9th, 05, 01:40 PM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,025
Post

TORCO synthetic racing oil 10W30
(better than royal purple)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #8 of 10 (permalink) Old Feb 9th, 05, 01:42 PM
Retired
Jim
 
click's Avatar
 
Join Date: Jun 2001
Location: Central Minnesota
Posts: 15,975
Post

10-w40 Amsoil 100% synthetic. purrs like a kitten [img]smile.gif[/img]

Click..is Jim..former owner of a 69RS-LM1 350/255 - 700r
"There will come a time when you believe everything is finished,
That will be the beginning." Louis L'Amour
click is offline  
post #9 of 10 (permalink) Old Feb 9th, 05, 08:11 PM
Senior Tech
Sean
 
Join Date: Feb 2002
Location: N.W. Washington
Posts: 7,963
Post

i run mobil 1 in everything, my camaro, truck, mustang, wifes volvo, even my lawn mower (seriously). i love the stuff.
i used to run only kendall in my mustang back when i was bracket racing it a lot, great stuff, but i switched to synthetic to see if i could get an extra edge. well, i dont know about the extra edge, but i had an oil pump relief fail and blew my filter apart, and drained my motor. the car was cold, so no smoke, plus i was about half asleep, and i didn't notice the zero pressure until i drove the car over 5 miles on the freeway! i kid not, i almost crapped my pants, but the car was running quiet and fine, so i actually thought the factory gauge died, as it was below zero. well when i pulled over i found the ugly truth. i figured the motor was done, so i filled it back up, put on a filter, and drove half an hour home (with my dad following), and the car ran same as ever.
i pulled the motor and tore it apart anyway, only to find.....nothing!, but a couple scratches in a main bearing. i had the crank polished, threw a set of bearings in, and the car is still running good today, 240K on the clock. i was amazed to say the least, and contributed the feat primarily to the syn it had in it.
just my story (its true), about syn oil [img]graemlins/thumbsup.gif[/img]

Sean

1968 rs with an old school 354" SB2.2 pump gas motor.

Repetition does not transform a lie into a truth.

Franklin D. Roosevelt
68rs406 is offline  
post #10 of 10 (permalink) Old Feb 10th, 05, 05:09 AM
Senior Tech
 
Join Date: Jun 2000
Location: Pittsboro, NC
Posts: 534
Post

I use Aimsoil 10w-40 in engine, 75w-90 series 2000 in rearend.

69 SS

69 project for my wife - SS 396, Glacier blue

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JayBird is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome