1984 quadra jet - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jul 29th, 03, 04:52 PM Thread Starter
 
Join Date: Jul 2003
Posts: 2
Smile

My buddy has a 1984 Z28 with a quadra jet carb, and for some reason his 4 barrels aren't kicking in. Anyone have any ideas?
phrozen is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 30th, 03, 05:44 AM
Senior Tech
Matt Jones
 
Join Date: Jan 2002
Location: Renton, WA USA
Posts: 2,765
Post

Who said the 4 barrels aren't kicking in?

The QJ only has 4 barrels; so if they aren't opening up, the car isn't moving. I'm assuming he means the secondaries aren't opening up...

On my 1986 QJ (which isn't a feedback type carb), there is a little vacuum pot that allows the secondary air flap to open up (the secondary throttle blades are mechanically hooked up to the primary, so they always open, the air flap just senses air flow and opens up when needed). I'm assuming that vacuum pot is not working correctly. Pull it off and test it with a vacuum pump.

Matt Jones
Lead Mechanical Engineer
Art Morrison Ent. Inc.
Silver69Camaro is offline  
post #3 of 4 (permalink) Old Jul 30th, 03, 06:07 AM
Gold Lifetime Member
Robert
 
Join Date: Oct 2000
Location: Simpsonville, SC
Posts: 3,359
Post

Another possible reason.... Not sure what year my Q-Jet is and I'm not real up on carb terminology but mine has some linkage connected with the air flap that is associated with the choke linkage. (I think) its function is to keep the secondary from opening until the engine reaches normal operating temperature. Anyway, it wasn't working and was the reason the secondary wasn’t opening on my carb. I've yet to fix it correctly but a piece of wire to hold the small piece of linkage in place has it working for now.

Robert

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
355ci 10:1, 64cc Edelbrocks, Comp Mag 280H, Performer RPM, 700r4 (2000 stall), 3.55 posi A/C PS PDB Hotchkis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
369ci 10.3:1, 64cc Edelbrocks, Voodoo 276/284, Performer RPM, Holley 650DP ...T56 Magnum, 3.73 Moser 12 bolt
TC member #18
rojo is offline  
 
post #4 of 4 (permalink) Old Jul 30th, 03, 05:11 PM Thread Starter
 
Join Date: Jul 2003
Posts: 2
Post

Thanks for the response. Could another possible reason for it be that his kickdown cable hasn't been working properly?
phrozen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome