P/S Pump compatibility - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 11th, 05, 01:32 AM Thread Starter
 
Join Date: Jan 2005
Posts: 4
Post

Sorry if this is in the wrong area, closest i could find and this is my first post!

I got a 1984 Camaro, 305 Small block engine, i have the oppertunity to replace my hole ridden power steering pump very cheaply, but it would be with a pump from a 1967 camaro with a 350 engine, it looks the same, the mounting brackets appear to be the same also, just wondering if anyone knew for sure if the pump is compatable.

Many thanx!
Awesome_Bryan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 11th, 05, 03:59 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

I'm not positive of the year it started, but they went to metric reverse flare fittings around then. Check the pressure fitting on the pump very carefully. You may be able to swap fittings with the old one,

What's cheap? I'd think an early 80's gm pump would be extremely cheap in a junkyard.

And btw, welcome to TC!





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 4 (permalink) Old Jan 11th, 05, 06:08 AM Thread Starter
 
Join Date: Jan 2005
Posts: 4
Post

Cheap is $10, but the original didnt have A/C, mine does, was told it will cause a problem. Have no idea how, im not a mechanic only ambitious. Think i wont take the risk.

Local garage have quoted me £65GBP for a new one. Thats a lot more than $10!!

Thanks for the help!
Awesome_Bryan is offline  
 
post #4 of 4 (permalink) Old Jan 11th, 05, 03:28 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

Sorry, Bryan, didn't see you were in England, guess you don't have too many junkyards full of old american iron.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome