67 327/275 Pulleys - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Sep 26th, 03, 07:18 AM Thread Starter
Senior Tech
Paul
 
Join Date: Sep 2001
Location: Queen Creek AZ
Posts: 3,677
Post

My 67 has power steering and I am wondering what the correct pulleys are for the engine.

Between Ricks and CRG I have identified the following pulleys as most likely being correct:

Two Groove Crank Pulley 3744043
Crank Extension for PS 3751232
Power Steering Pulley 3860457
Two Groove Water Pump Pulley 3900434(CRG) or ????643(Ricks)

Can anyone verify which pulleys would be correct for my 327/275 with power steering?

Best of 1.55 - [email protected]
paulm is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Sep 26th, 03, 12:19 PM
Senior Tech
Mark
 
Join Date: Feb 2002
Location: LR AR
Posts: 2,372
Post

The CRG has a downloadable pulley spreadsheet that lists all the pulley numbers for all first gen Camaro's. It is very helpful for this type of research.

-Mark.
stingr69 is offline  
post #3 of 6 (permalink) Old Sep 26th, 03, 01:33 PM Thread Starter
Senior Tech
Paul
 
Join Date: Sep 2001
Location: Queen Creek AZ
Posts: 3,677
Post

Between talking to the guys at Ricks and reading the CRG Pulley PDF, that's how I got the numbers so far.

Best of 1.55 - [email protected]
paulm is offline  
 
post #4 of 6 (permalink) Old Oct 3rd, 03, 08:15 PM
Gold Lifetime Member
Mike
 
Jonesy's Avatar
 
Join Date: Oct 1998
Location: Minnesota
Posts: 6,465
Post

I have a Two Groove Crank Pulley 3744043 and a Two Groove Water Pump Pulley 3900434

The were off a car with power steering and I think it had A/C

Team Camaro Gold Member #14

1967 Camaro RS/z28 - one of 602 made - SOLD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Camaro RS/SS L48 4 speed
1974 Camaro LT-Z/28 4 speed 33K orig miles
1979 Camaro Z/28 36K orig miles
1987 Monte Carlo SS 25K orig mi bought new by me.
Jonesy is offline  
post #5 of 6 (permalink) Old Oct 4th, 03, 08:16 AM Thread Starter
Senior Tech
Paul
 
Join Date: Sep 2001
Location: Queen Creek AZ
Posts: 3,677
Post

You have those on your 69?

Best of 1.55 - [email protected]
paulm is offline  
post #6 of 6 (permalink) Old Oct 4th, 03, 03:02 PM
Gold Lifetime Member
Mike
 
Jonesy's Avatar
 
Join Date: Oct 1998
Location: Minnesota
Posts: 6,465
Post

No they are extras I had sitting around the garage. I looked them up to see what they went on.
I believe they are for 1967 SS 350

Team Camaro Gold Member #14

1967 Camaro RS/z28 - one of 602 made - SOLD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Camaro RS/SS L48 4 speed
1974 Camaro LT-Z/28 4 speed 33K orig miles
1979 Camaro Z/28 36K orig miles
1987 Monte Carlo SS 25K orig mi bought new by me.
Jonesy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome