Oil pick up tube - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 16th, 05, 11:54 AM Thread Starter
Tech Team
 
Join Date: Jan 2003
Location: California
Posts: 31
Post

Has anyone used loc-tite or J-B liquid weld on the pick up tube? If so, any negative results, like it falling out? People have suggested a couple of weld spots, but if that's not an option, I would like to have feedback from those using loc-tite red or the J-B Weld.
Karens68 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 16th, 05, 12:49 PM
 
Join Date: Apr 2000
Posts: 21,341
Smile

I safety wired mine on with a couple of turns of concrete re-bar "tie-wire"..

I didn't have access to a welder or I would have spotted it on after removing the spring and such..

pdq67



pdq67 is offline  
post #3 of 5 (permalink) Old Jan 16th, 05, 01:00 PM
Moderator
Bill
 
Join Date: Aug 1998
Location: Waldorf Md. USA
Posts: 3,288
Post

Karen,
If it is installed properly, with the correct tool as I described in your other post, it should not come out. The factory ones are not welded and they stay in place just fine but .... they are installed properly to begin with. If the tube goes in even the slightest bit crooked, or has to be turned at all after it is pressed in place ... you will have problems and I would not want to trust loctite to keep it in place.
You certainly do not want JB weld anywhere near it ... if even a small peice breaks off later ...

Bill Koustenis
Owner
Advanced Automotive Machine
Waldorf Md
1971 Chevelle "Heavy Chevy" original owner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillK is offline  
 
post #4 of 5 (permalink) Old Jan 18th, 05, 05:36 PM
 
Join Date: Aug 2003
Posts: 154
Post

Please do not cheap out at this point. Why go out and buy 4K+ in a crate motor to have it blow up over an extra $20 to 30 in a new oil pump and pick-up
WillS is offline  
post #5 of 5 (permalink) Old Jan 23rd, 05, 06:16 PM Thread Starter
Tech Team
 
Join Date: Jan 2003
Location: California
Posts: 31
Angry

We took everyone's advice and had the new pick-up tube welded in place.
Thanks to everyone who responded.
Karen & Tom
Karens68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome