fuel system problems New 350 ho deluxe - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 6th, 03, 07:05 AM Thread Starter
 
Join Date: Nov 2001
Posts: 32
Post

I've just installed a new 350 HO Deluxe into a 67' Camaro. I am having fuel system problems. The mechanical pump won't work, the fuel pump pushrod does not move in & out when the engine is turning. I installed a Holley "red" elect. pump, but it seems to flood the carb. Is this engine intended for a elec. fuel pump, or will the standard GM sb chevy pushrod the wrong size?
sixty8rs is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 6th, 03, 07:58 AM
Gold Lifetime Member
Rick
 
Join Date: Feb 2000
Location: Accord, NY
Posts: 4,815
Post

I will venture a guess that your cam does not have the eccentric lobe to drive the fuel pump pushrod, or, the pushrod is not on the lobe if you installed it yourself.

However, you need a fuel pressure regulator with that elec pump.

Rick Dorion
69 RS Conv therapy program, Autogear M22, 8-pt cage, with a new 410! SOLD
New therapy program - 68 Coupe. Will be survivor exterior, modern underpinnings! SOLD
67 Belair with perfect floors, pinchwelds and firewall. Hmmm!
RickD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome