fuel pump -- top holes leaking oil - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 5th, 04, 08:28 AM Thread Starter
 
Join Date: Jun 2002
Posts: 11
Post

Guys,

I purchased a new gm street performance fuel pump(mechanical) from Pace performance. Installed it onto a new crate motor. It seemed to work fine for the first 800 miles, but now it leaks oil out of two holes on the top side of the fuel pump. Does anyone know why this happens? What are these two holes on top of the fuel pump for? Seems to happen at higher RPM's and not idling. Is the pump bad? What would cause a new pump to go bad so soon. If you sucked foreign material from the gas tank can this cause a problem with the pump? Can it be leaking fuel into the oil? How can I tell if fuel is in the oil? Will it have a strong gas smell?
kconaway is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 5th, 04, 08:58 AM
Senior Tech
Brandon
 
Join Date: May 2004
Location: Monroe, NC
Posts: 2,089
Garage
Post

Sounds like its time for a new pump. Yes it can leak fuel into the oil if the diaphram blows. You will definately smell gas in the oil if this ocurrs.

No clue what the two holes are for on top

Brandon J. licence 1NASTY67

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nantooch is offline  
post #3 of 3 (permalink) Old Sep 5th, 04, 09:57 AM
Senior Tech
Bob
 
Join Date: Dec 2000
Location: Ct.
Posts: 1,145
Post

Get a Carter 120 gph fuel pump.CHECK YOUR OIL NOW!!! If it is over full or smells like gas then change it before you run your engine.Your new pump is shot.The diaphram is letting oil by. I have had the same problem with an Edelbrock pump. I still like Edelbrock stuff, just not their fuel pumps.

Bob
Garnet Red 69/SS396/TH400/355 Posi Sold
'02 triple blk Vette Vert. now
94 HD Dyna Wideglide
phel69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome