Runs rough during acceleration - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 10th, 04, 08:01 AM Thread Starter
Tech Team
 
Join Date: Apr 2004
Location: Northern California
Posts: 57
Send a message via AIM to Samuel
Post

Hey,

I just got my 67 camaro 350 back from the shop two days ago. They fixed my oil leak and the car ran fine. Bad news though, I took it out for a cruise just now and when I accelerated, the engine ran rough and was chugging. The more I accelerated, the worse it got. There was also a ticking sound I could hear coming from the engine compartment. Could all of this be the result of a vaccuum leak, timing, or spark plugs? (I recently advanced the timing a little bit) Any input would be greatly appreciated.

Thanks, Samuel

1967 Camaro SS. See pictures of it here: <a href="http://community.webshots.com/user/sbwell1020" target="_blank">http://community.webshots.com/user/sbwell1020</a>
Samuel is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 10th, 04, 08:42 AM
Senior Tech
Kevin
 
Join Date: May 2004
Location: Kansas
Posts: 342
Post

I would check the timing. I have a ford truck that I advanced the timing on and it did EXACTLY the same thing. That is where I would start anyway.

1968 SS 350 Camaro, 4-speed, California car, restoration complete. Brought back to life after almost 27 years of silence!

Built: 3rd week of July, 1968
Silenced: 12/12/1978
Resurrected: 05/01/2005
68SSCamaroinKS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome