valve problem? - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Jan 16th, 17, 05:53 PM Thread Starter
Probationer
randy
 
Join Date: Jan 2017
Location: oxford,oh
Posts: 4
valve problem?

I have a 1969 numbers matching 302 engine. The drivers side valve cover has grooves on the inside cover on the bottom or valve side of cover. all 8 valves have grooves in cover. the passenger side is fine. any thoughts?
randy69 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jan 16th, 17, 06:46 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: valve problem?

Quote:
Originally Posted by randy69 View Post
I have a 1969 numbers matching 302 engine. The drivers side valve cover has grooves on the inside cover on the bottom or valve side of cover. all 8 valves have grooves in cover. the passenger side is fine. any thoughts?
You mean the rocker arms are grooving the cover?

Try flipping the driver's side valve cover over.

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
post #3 of 6 (permalink) Old Jan 16th, 17, 06:47 PM
Gold Lifetime Member
Don
 
Join Date: Jan 2005
Location: 2 Dog Town in West Texas
Posts: 11,154
Re: valve problem?

Is the oil filler cap on the right or left side with this cover? My first thought is they are upside down.

The long little knotches are supposed to fit around intake manifold runners.

Don
TC # 349
Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E Owner since Dec 1968

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zdld17 is offline  
 
post #4 of 6 (permalink) Old Jan 16th, 17, 07:49 PM Thread Starter
Probationer
randy
 
Join Date: Jan 2017
Location: oxford,oh
Posts: 4
Re: valve problem?

Oil cap is on back side of drivers side and pvc valve on front of drivers side. it looks like valve spring is touching as it has ringed grooves on valve cover.
randy69 is offline  
post #5 of 6 (permalink) Old Jan 16th, 17, 08:33 PM
Senior Tech
Mark
 
Join Date: Sep 1998
Location: Ontario, Canada
Posts: 2,009
Garage
Re: valve problem?

Post a photo. I have no clue what your talking about.

Mark 70 Z28 M22 3.73 Z21 Z87 - Lunati 20120121 Roller Cam

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
COPO is offline  
post #6 of 6 (permalink) Old Jan 16th, 17, 08:38 PM
Gold Lifetime Member
Don
 
Join Date: Jan 2005
Location: 2 Dog Town in West Texas
Posts: 11,154
Re: valve problem?

Quote:
Originally Posted by randy69 View Post
Oil cap is on back side of drivers side and pvc valve on front of drivers side. it looks like valve spring is touching as it has ringed grooves on valve cover.
Sounds like the valve spring is bouncing around. Springs should be be in their pocket on the head but from what you are saying the valve spring or retainer is what is cutting the cover. I have seen some bad valve guides and weak springs allow this..
What do you know about this motor? Been yours forever? Any chance someone put longer valves or larger springs in this head? Any chance of the rocker arm hitting the cover?

Don
TC # 349
Zdld17:69 Z/RS,306, NOR141111, 9N554XXX, 12A, X3G, 59/59,723, AFR 195,CCC282/290HR, TKO 600, BU1122B1E Owner since Dec 1968

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zdld17 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome