Hei distributor no spark - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 31st, 18, 11:15 AM Thread Starter
LP
Probationer
Larry
 
Join Date: Feb 2018
Location: Virginia
Posts: 4
Hei distributor no spark

I have a 2007 350 crate engine 330 HP model with HEI ignition, not getting spark to the plugs. A few years back I had the similar problem and replaced the module. I've read a few articles on how to check some of the other parts of the system,ie,coil, pick up etc. How long does a module usually last if it is indeed the problem. Any thoughts would be appreciated.
LP is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 31st, 18, 12:41 PM
Senior Tech
kevin
 
Join Date: Mar 2012
Location: virginia
Posts: 3,541
Re: Hei distributor no spark

Quote:
Originally Posted by LP View Post
I have a 2007 350 crate engine 330 HP model with HEI ignition, not getting spark to the plugs. A few years back I had the similar problem and replaced the module. I've read a few articles on how to check some of the other parts of the system,ie,coil, pick up etc. How long does a module usually last if it is indeed the problem. Any thoughts would be appreciated.
sometimes like a light bulb . new today bad 2 hours later
flat tire is online now  
post #3 of 5 (permalink) Old Dec 31st, 18, 01:22 PM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,213
Garage
Send a message via MSN to DOUG G
Re: Hei distributor no spark

Be sure the wires are connected and triple check your ground.

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
 
post #4 of 5 (permalink) Old Dec 31st, 18, 02:21 PM Thread Starter
LP
Probationer
Larry
 
Join Date: Feb 2018
Location: Virginia
Posts: 4
Re: Hei distributor no spark

Thanks
LP is offline  
post #5 of 5 (permalink) Old Dec 31st, 18, 03:28 PM
Moderator
____
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,213
Garage
Send a message via MSN to DOUG G
Re: Hei distributor no spark

Meant to say connected correctly...

68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome