Need some help - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Sep 17th, 05, 01:04 PM Thread Starter
 
Join Date: Sep 2005
Posts: 5
Need some help

I bought my 96 Camaro on monday, it has a 3.8L V6, it ran fine for a couple of days, then after it had been running awhile i was driving and stopped at a red light and all of a sudden it felt like it was going to die, had a rough idle, big loss of power and it responded late to the pedal and would kinda play out when id press the pedal like it was skipping or stuttering. Well one of the plugs on one of the coils was not making sparks so i replaced the coil, and all the others seem to be working fine, well i had my power back, but that stuttering was happening again. what could this be? the plug from the coil? a spark plug? Fuel injector? pleez help fast thanx
KillaCam is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Sep 17th, 05, 05:09 PM
Moderator
Bill
 
Join Date: Aug 1998
Location: Waldorf Md. USA
Posts: 3,290
Re: Need some help

Killa,
Please post questions to only one forum. It keeps from things getting confusing and helps in the future if someone remembers your problem and wants to search for it. I am going to lock this thread since you already have a couple of responses in "troubleshooting"
Thanks,

Bill Koustenis
Owner
Advanced Automotive Machine
Waldorf Md
1971 Chevelle "Heavy Chevy" original owner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillK is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome