Not Camaro -- Jeep related?? - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old Oct 22nd, 05, 01:43 PM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Unhappy Not Camaro -- Jeep related??

Our Daughter and Son-in-Law have a 2001, Jeep Grand Cherokee Larado, 4.0 L straight-6, auto that has recently started to not stay running when she takes her foot off the gas to hit the brakes. (About 75 to 80,000 miles on it)..

I bought new plugs and an air filter and am going to see if it has an external fuel line gas filter on it b/c O'Reilly's said they thought it had an in-tank filter?? (Don't know which it has???)....

What else should I be looking for to try to get it running right for her??

OR should I just install the plugs and air filter AND tell her to take it into the Dealer for a diagnostic and have them do whatever it takes to get it back running right?? (I hate crap like this!!)...

Any help is GREATLY appreciated here b/c I don't know squat about a Jeep!

pdq67



pdq67 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old Oct 22nd, 05, 02:10 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Not Camaro -- Jeep related??

Paul, I had a Grand Cherokee V8 that did that. Problem was that the idle air control motor was gummed up. I took it out and cleaned it good, and it worked like a champ after that.

The IAC is an alluminum cylinder, about an inch in diameter and an inch long, with 2 mounting ears at the base and 2 screws holding it on, attaches to the throttle body. Has an electrical connector with 2 or 3 wires. It pulls right out, you'll see how it comes apart.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 15 (permalink) Old Oct 22nd, 05, 05:28 PM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Smile Re: Not Camaro -- Jeep related??

Thanks Jim,

I feel so useless trying to work on the new cars.....................

pdq67



pdq67 is offline  
 
post #4 of 15 (permalink) Old Oct 22nd, 05, 08:21 PM
 
Join Date: Mar 2004
Posts: 537
Re: Not Camaro -- Jeep related??

pdq, I know how you feel bud, my best friend has a 99 grand cherokee with the 4.0L, everytime something goes wrong its a PITA to fix.

not to mention all the failed parts he's had.



he just installed some upcountry springs today, drives like a champ
aonghus is offline  
post #5 of 15 (permalink) Old Oct 22nd, 05, 09:53 PM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Smile Re: Not Camaro -- Jeep related??

I'm jumping into it tomorrow after Church.

pdq67



pdq67 is offline  
post #6 of 15 (permalink) Old Oct 23rd, 05, 01:05 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Not Camaro -- Jeep related??

ginne a holler if you need anything... should be pretty easy. There's a piston that sticks into the idle air bypass hole, just pretend itsa carb and clean it all out.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #7 of 15 (permalink) Old Oct 23rd, 05, 01:50 PM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Smile Re: Not Camaro -- Jeep related??

Here is what I found out.

I took off the breather hat and sprayed the hole, (that Jim mentioned), full of O'Reilly's carb. cleaner three times while working the butterfly that Jim mentioned, two times cold and started in between and the third time warm, after we came back from a couple of parts stores.

Seems a while back my daughter had the drivers side P/W fixed and the Mechanic didn't bother to tighten down the positive battery terminal very good at all! Bordered on being hand tight!!

I went to O'Reilly's and asked them to check the battery AND of course, it's some low! Plus, the alt. shows a bad diode? I then went home an cleaned both terminals and my Son-in-Law and I drove it around a bunch as we watched the alt. bring the battery up to full charge..

O'Reilly's and American Auto don't show a part # for an alt. so go figure!! 2001 Jeep! Give me a break.................

I told my Daughter to drive it and that I would see if I could turn up an alt. on the web as well as she probably will want to install a new battery too since it is 4 years old anyway! Heck, a stock battery is good to go three years, imho...

Thanks Jim for the heads-up on that little gizmo!! AND a bunch of dark gray crap came out of it!!

pdq67



pdq67 is offline  
post #8 of 15 (permalink) Old Oct 23rd, 05, 02:34 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Not Camaro -- Jeep related??

yw paul, not a prob....does she idle a bit better now?

other than the darned electronics, new cars ain't no different than old, still just need fuel, compression and spark to make a fire.

Just takes some experience to get the hang of it, and I just happened to have experienced this one on a chrysler efi.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #9 of 15 (permalink) Old Oct 23rd, 05, 03:45 PM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Thumbs up Re: Not Camaro -- Jeep related??

Right Jim and thanks again.

pdq67



pdq67 is offline  
post #10 of 15 (permalink) Old Oct 24th, 05, 09:24 PM
Senior Tech
Johnny
 
Join Date: Dec 1999
Location: Rutledge, Tn.
Posts: 610
Smile Re: Not Camaro -- Jeep related??

My wife has a 2000 Jeep Grand Cherokee Lardo with the 4.0 engine in it & my sister has the same & on both of them I have learned that you have to keep the Battery termials clean & super tight or they will drive you crazy. They will not run right if one or both of the battery termials are loose or dirty. They will miss, quit, hard starts, rought idle, They will not run right unless they have fully charged battery's with good conections.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
johnnyr is offline  
post #11 of 15 (permalink) Old Oct 25th, 05, 07:25 AM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Angry Re: Not Camaro -- Jeep related??

You know I tend ta be paranoid and sort of a Conspiracy type, but for the life of me, I don't understand Mechanics that would leave a positive battery terminal nut loose!

I want to slap sombody!!

Bad, bad, bad!!

I hate to have to walk round my car after I get it home after somebody took it out of my sight to work on it to see what else they screwed with! You know, changed good lightbulbs out for burnt out ones, left wheel valve stem caps loose, loose oil pan bolts, etc... And now loose battery terminals!!

pdq67



pdq67 is offline  
post #12 of 15 (permalink) Old Nov 1st, 05, 12:59 PM
Senior Tech
Dave
 
Join Date: Jun 2002
Location: Rolla, MO
Posts: 465
Re: Not Camaro -- Jeep related??

It must be going around, PDQ.... my wife's 99 Grand Cherokee Limited (v8) is now having start up issues. Almost seems like it's not getting fuel at first. Sometimes it starts, sometimes it has to crank a loooong time before it starts. Would the fuel pump be intermitten like? Is the fuel pump in the tank? Am I even on the right track?

68 Camaro Roller | 68 Camaro (#matching) | 69 Camaro
KWIK 69 is offline  
post #13 of 15 (permalink) Old Nov 1st, 05, 02:35 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Not Camaro -- Jeep related??

you might try cleaning the IAC, too. If it's stuck all the way closed the motor won't get enuf air to idle when it's cold, but might be ok warm. At any rate, it's about the easiest thing to do on a modern efi system, and impossible to screw up (did I say impossible? )





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #14 of 15 (permalink) Old Nov 2nd, 05, 04:12 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,750
Garage
Re: Not Camaro -- Jeep related??

At least y'all's Jeep GC's run, mine doesn't, but then, I bought it in this condition. Needs an engine.

Thinking about farming the job out. Can't see the ground with the hood open. just another project, I suppose.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
post #15 of 15 (permalink) Old Nov 2nd, 05, 06:22 AM Thread Starter
 
Join Date: Apr 2000
Posts: 21,341
Angry Re: Not Camaro -- Jeep related??

I know what you mean. I was looking for the battery in the wife's Buick and the SOB has what appears to be terminals sticking out one end with them stacked??? Maybe, maybe not, b/c it also had a double cover on it so I just shut the hood and said to h-ll with it and used the battery in my old P/U to air my bicycle tires up with!!

And btw, the daughter said her Jeep is still running fine!

AND I forgot to mention that somebody had changed out the hood holder shocks for two bad ones b/c the Jeeps hood WON'T stay up now and I'm sure it did whenever I first looked at it when she got it so AGAIN, go figure!!!

Bad, Bad, Bad!!

pdq67



pdq67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Holy Cow New CAMARO!!!!! BBC1 Bench Racing 39 Jan 10th, 06 08:15 AM
Nit Camaro related, but Olds related. 68 Convert Engine 5 Jul 11th, 05 10:41 PM
Nit Camaro related, but Olds eelated. 68 Convert Engine 1 Jul 11th, 05 08:49 PM
CAMARO IS BACK IN 2007!!!!!!!!!!!!!!!!!!!!!!!!! dawg Bench Racing 32 Apr 24th, 05 08:27 PM
Need Help (not camaro related) huggerZ Bench Racing 5 Nov 5th, 04 11:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome