power loss - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Oct 28th, 05, 03:55 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 3,003
Talking power loss

hi, can timing affect power loss when accelerating but run fine when idling?
my car seems to run fine butwhen you drive it, the car hesitates and i have noticed a drastic drop in acceleration and power.

thanks for your thoughts
steven

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Oct 28th, 05, 05:34 PM
Senior Tech
 
Join Date: Jul 2005
Location: Ga.
Posts: 440
Re: power loss

Low or retarded spark timing will cause an engine to run sluggish and run hotter than normal. Loose distributors are the culprit many times. They back off and retard the timing as the engine is running.
69cama is offline  
post #3 of 8 (permalink) Old Oct 28th, 05, 05:53 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 3,003
Re: power loss

when you say run hotter, do you mean the water temp rises?

mine runs at on or about 160-180 degrees

thanks
steven

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
 
post #4 of 8 (permalink) Old Oct 28th, 05, 06:08 PM
Senior Tech
 
Join Date: Jul 2005
Location: California
Posts: 2,353
Re: power loss

yes, well sort of
it may want to run hotter but your cooling system may still be albe to keep it cool, does it get to normal temp sooner than normal?
400bird is offline  
post #5 of 8 (permalink) Old Oct 28th, 05, 06:53 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 3,003
Re: power loss

no, when i first start the car i have to keep my foot on the gas pedal to keep it from stalling. about after a minute it will idle on its own.

it reaches normal operating temp after about 5min of idling on its own

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
post #6 of 8 (permalink) Old Oct 28th, 05, 08:14 PM
Senior Tech
 
Join Date: Jul 2005
Location: California
Posts: 2,353
Re: power loss

well it doesnt take but a min to check your timing
400bird is offline  
post #7 of 8 (permalink) Old Oct 28th, 05, 11:54 PM Thread Starter
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 3,003
Re: power loss

so if the timing checks out ok, what else could be the problem?

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
post #8 of 8 (permalink) Old Oct 29th, 05, 12:28 AM
Senior Tech
 
Join Date: Jul 2005
Location: California
Posts: 2,353
Re: power loss

fuel supply? could be as simple as a clogged filter
400bird is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
79 power window question SirKnite Electrical & Wiring 0 Jul 28th, 05 05:10 PM
68 power steering burner Brakes, Suspension & Steering 2 Apr 2nd, 04 10:47 AM
Supercharger power steering problem need A-Body Procharged69 Tech 2003 5 Oct 22nd, 03 11:44 AM
Power Loss MaxR Troubleshooting 1 Feb 2nd, 03 09:42 PM
Loss o Power under 3,000 rpms Ay96SS Troubleshooting 2 Jun 21st, 02 09:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome