bad lifter? - Team Camaro Tech
Engine General Engine Discussion.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 31st, 05, 12:30 PM Thread Starter
Senior Tech
 
Join Date: Jan 2005
Location: tulsa,ok
Posts: 109
Send a message via AIM to 67camaro02
bad lifter?

this problem started about a week ago. Whenever i start the motor up when its cold the car makes a weird noise from the motor and it runs really rough. This usually only lasted for about 10 seconds or so then it would go away and run smooth.

Well when i started it up yesterday the noise didnt go away for like 2 minutes or so then on the way to work it just started doing it constantly. I pulled the valve cover off and the rocker arm was completely off the pushrod and spring. The not on the stud didnt not come loose either. Does this sound like a lifter to you? What else should i check? thanks
67camaro02 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 31st, 05, 05:01 PM
Senior Tech
Scott
 
Join Date: Sep 2005
Location: Ontario, Canada
Posts: 102
Re: bad lifter?

CHeck the cam also. I just pulled my lifters out and found one damaged. The lobes wear mark looks funny also compared to the rest.
DirtyScotty is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad lifter or bad camshaft? DirtyScotty Engine 11 Oct 30th, 05 05:36 AM
Bad window switch or bad motor Meanchicken Electrical & Wiring 2 Oct 3rd, 05 06:41 AM
Setting Pushrod Length - Solid/Hydrolic lifter JHunter Performance 2 Aug 2nd, 05 10:19 PM
Rhodes hydraulic lifters jlighthart Engine 13 Feb 23rd, 03 03:45 PM
roller rockers Lil Greg Performance 9 Feb 12th, 01 04:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome