Hi-Perf Battery Question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 15th, 07, 08:01 PM Thread Starter
 
Join Date: Dec 2005
Posts: 55
Unhappy Hi-Perf Battery Question

I am running a 69 coup with a 502/502 crate with upgrades including a MSD 6al with electronic MSD distributer. I have put several electrical components such as Holley Blue pump, 2 fans, gauges, Monster Tach and trans brake. I recently installed Halogen headlights. I realized I would loose voltage but figured the 100 amp alternator would compensate. I was wrong. My voltage gauge drops to under 10.5v at idle and won't go over 11.5. This is not enough and I have killed the performance of my ride. My question....which HI-Perf battery is the best? I just have a regular Bosch 800ca battery, or is there something else I should do. The car is basically stock with everything. Wipers, heater, lights, dash ect...
Look at the pics, it is a street car. A guy at a car show said that if I get a Marine Yellow top Gel, it would solve all problems. Another guy said to get a 16volt??? Everything is 12v in the car. Any help would be great.
Bzajr3 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 15th, 07, 09:23 PM
Senior Tech
Eric
 
Join Date: Jan 2005
Location: North Carolina
Posts: 601
Re: Hi-Perf Battery Question

It sounds like you need to improve the charging system a little further. The car should only need the battery for starting, and for helping out when a sudden surge is needed, the rest of the time the charging system needs to provide enough juice to run everything. If you have a 100 amp alternator, did you upgrade the wiring so you can get all 100 amps out of it? I would start with finding out why your charging system is not keeping up. Either your charging system has some problems, or you have something (or several somethings) drawing too much current.

ERIC
67 Convertible, 350CID, TKO600RR, 3.73 Eaton Posi
ept000 is offline  
post #3 of 4 (permalink) Old Feb 15th, 07, 09:46 PM
Gold Lifetime Member
 
Join Date: Mar 2006
Location: Chi-town's South Side
Posts: 2,411
Re: Hi-Perf Battery Question

I agree with ept. I went with a Powermaster 140 Amp Alternator. But as he said check your charging system first, then check to see if things are drawing more current than they should.

1) 1969 Camaro RS 396 TH 400, 12 bolt 3:73 sold 1994
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2) 1984 Z28, 5.0 H.O. T-Tops, G92 3:73, sold 1994
3) 1988 5.7L IROC-Z, sold 1994
4) 1969 Camaro bought 2006, back on the road in 2010
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
South Side Goons & Hitmen is offline  
 
post #4 of 4 (permalink) Old Feb 16th, 07, 07:18 AM
Senior Tech
Jim
 
Join Date: Jul 2005
Location: MA
Posts: 1,913
Send a message via Yahoo to go2fast
Re: Hi-Perf Battery Question

Is your alternator a one wire setup? If it is, that's probably part of your problem. As others have said, a bigger battery is not the answer.
go2fast is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery to Junction block question? ENP Electrical & Wiring 2 Aug 24th, 06 06:21 AM
Alternator Battery Lead Eric Kammerer Electrical & Wiring 1 Aug 22nd, 06 04:15 AM
battery being drained oddiseeus Troubleshooting 7 Nov 6th, 05 06:56 PM
Battery keeps draining on me.....help! Granny's 69 Electrical & Wiring 5 Aug 18th, 05 07:24 AM
Battery question garfield Engine 9 Sep 17th, 03 02:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome