LT1 doesn't like the rain - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Feb 26th, 07, 06:14 PM Thread Starter
 
Join Date: Feb 2007
Posts: 7
LT1 doesn't like the rain

i have a 94 firebird that won't start if it has rained hard if it does start i get white smoke and a very strong gas smell
david cooper is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Feb 26th, 07, 06:33 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: LT1 doesn't like the rain

yer optispark distributor is shot





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 5 (permalink) Old Feb 26th, 07, 06:52 PM
Senior Tech
Adam
 
lortsie's Avatar
 
Join Date: Aug 2005
Location: Hubbard, OR
Posts: 633
Re: LT1 doesn't like the rain

Yep, the good news though is you can now get a quality aftermarket replacement from MSD through Summit for a lot cheaper than an OEM one. Until recently that repair would cost you $3-400. The MSD's are less than $200 if I remember correctly.

Throw on new plug wires with some dielectric grease, properly gapped plugs and an OEM style coil from MSD and you'll be running like new

Good luck wrestling with that water pump!

67 RS/SS "YELR67"
lortsie is offline  
 
post #4 of 5 (permalink) Old Feb 26th, 07, 07:14 PM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,487
Garage
Re: LT1 doesn't like the rain

Quote:
Originally Posted by david cooper View Post
i have a 94 firebird that won't start if it has rained hard if it does start i get white smoke and a very strong gas smell
Does it start and run properly after the rain?

If it is your opti there are rebuild kits available now as well...

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #5 of 5 (permalink) Old Mar 1st, 07, 05:02 AM
Senior Tech
Ken
 
Join Date: Mar 2006
Location: brandon manitoba canada
Posts: 267
Re: LT1 doesn't like the rain

I don't like starting anything in the rain either!!
kgmunro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lt1 mkpatrick Bench Racing 18 Jan 22nd, 07 10:10 PM
1970 Z28 Lt1 69z28freak Engine 0 May 25th, 06 10:24 PM
Rain, Rain, go away... zuma Bench Racing 29 Apr 12th, 06 08:47 PM
1970 LT1 question nikkisdad Bench Racing 11 Feb 21st, 06 12:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome