Can't get right turn signal working?? - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 25th, 07, 06:47 PM Thread Starter
Senior Tech
 
Join Date: Apr 2001
Location: Newark, Ohio
Posts: 706
Can't get right turn signal working??

I just can't seem to get me right side turn signals to work. It worked for 2 years then after I got the car out of winter storage today, it just won't work. Plus my GEN light is on now. I have a fairly new Optima battery that reads 12.45 volts at the battery without the car running. I have a whole new front wiring harness and engine harness last year and it worked fine then. I checked the back bulb and its fine, I haven't checked the front bulb yet. The fuse in the fuse block is fine and tried 2 different fuses for the big round fuse under the dash with the spade prongs on it. I am not sure where else to check. i am not sure what grounds to check. Any help would be great!!!!

Thanks, Erik

67 Camaro Pro Street, 540 Bill Mitchell Merlin big block, Merlin Aluminum heads, Holley 870, hydraulic camshaft, 2" Hooker Super Comp headers, Mallory and Crane ignition system, TH400, 2600 stahl, Ford 9" w/ 4:10 gears and posi.
Erik Beckett is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 25th, 07, 07:17 PM
 
Join Date: Jan 2007
Posts: 601
Re: Can't get right turn signal working??

well if you just got at out of storage maybe a mouse got into the wires and ate them. for the alt light on got to check running got to be over 13 but not over 14.5 as for turn signal you can check with a light hook to power and ground and should blink. but does the light inside even come on and dont blink or not.
jaguareats is offline  
post #3 of 4 (permalink) Old Mar 25th, 07, 08:36 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Can't get right turn signal working??

need more details, Erik.

On the gen light, what is the battery voltage when it's running?
you could try removing ans reinstalling both the regulator and the small 2 wire atlernator connector, that might fix it.

On the turn signal, do any of the bulbs light up but not blink?
or nothing at all?
Do both brake lights work normally?
All 4 running lights?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 4 (permalink) Old Mar 26th, 07, 02:45 PM Thread Starter
Senior Tech
 
Join Date: Apr 2001
Location: Newark, Ohio
Posts: 706
Re: Can't get right turn signal working??

Well, I got the turn signal to work, the bottom of the buld had one of the solder bumps broken off. But know my right turn signal in the dash doesn't work even know all the lights on the car work. Could I just have a blown bulb in the dash?

As far as the gen light goes. i have 12.5 volts at the battery with the car not running. i haven't checked while running. i will today i hope.

Thanks, Erik

67 Camaro Pro Street, 540 Bill Mitchell Merlin big block, Merlin Aluminum heads, Holley 870, hydraulic camshaft, 2" Hooker Super Comp headers, Mallory and Crane ignition system, TH400, 2600 stahl, Ford 9" w/ 4:10 gears and posi.
Erik Beckett is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Blowing Fuse DeeGee Electrical & Wiring 5 Sep 2nd, 06 07:02 PM
No right rear turn signal or hazard Obxhokie Electrical & Wiring 6 Jul 9th, 06 07:00 PM
Turn Signal cancelling JimM Electrical & Wiring 1 Apr 5th, 04 05:50 PM
light switch and turn signal roho29 Electrical & Wiring 0 Mar 28th, 04 02:27 PM
Tail Light Short & Turn Signal Switch KED67 Electrical & Wiring 3 Jun 25th, 01 09:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome