1967 wiring question - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Apr 3rd, 07, 12:26 AM Thread Starter
 
Join Date: Apr 2007
Posts: 2
1967 wiring question

I have a 67 camaro, when I hook the battery up it causes a relay to click/operate. The relay is located to the left of the dash headlight switch in the fender above the kick panel area. It looks to be a factory relay wired in with the stock loom but I can't find the relay noted in any of my books. All I can see is there is a Red with white strip and a Orange with black strip wires attached through a factory plug.
More Detail. In the factory wiring there is the large cable going to the starter solinoid from the positive post, then there is a smaller lead 14R going to a junction point on the radiator support and that lead turns into 10R which looks to go to the horn relay, volt reg, and alternator. The relay operates when I touch the 14R wire to the positive post. Could you help me indentify this relay and why it is operating by touching 14R to the positive post of the battery. Thanks, Jim
Jim Beardsley is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Apr 3rd, 07, 05:15 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,861
Garage
Re: 1967 wiring question

Try here:

https://www.camaros.net/forums/showth...790#post755790

The red pigtail from the positive battery cable is the power lead for the whole car. Buss bar on the horn relay is a tie point for battery and rest of the car. You will find a red wire going from this power circuit to the firewall for ignition, accessory power, and lights.

Welcome to the Club from the Beach! Be sure the frig door is shut when you leave.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden Ö enjoy your next chapter.
Everett#2390 is online now  
post #3 of 5 (permalink) Old Apr 3rd, 07, 10:27 AM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,509
Re: 1967 wiring question

What kind of options on the car. The only relay looking thing (I think its actually a circuit breaker) thats up in the kick panel area is for the power windows option. that harness doesn't show up in the assembly manual, or the wiring diagrams, but its in the fisher body manual. Does the car have, or did it have at one time, power windows?

Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mark C is offline  
 
post #4 of 5 (permalink) Old Apr 5th, 07, 12:43 PM Thread Starter
 
Join Date: Apr 2007
Posts: 2
Re: 1967 wiring question

Yes, the car does have power windows and I do see in the Body by Fisher1967 service manual page 16-23 a diagram showing a ingnition relay. I that what you are talking about? My relay is definately a relay and not a curcuit breaker. It is definately clicking when I add power, in fact I can hear a spring sound when I remove the power. I just had the interior done. Could the interior guy have shorted out the power windows? What would be the best way to shot trouble in the power windows?
Jim Beardsley is offline  
post #5 of 5 (permalink) Old Apr 5th, 07, 01:02 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: 1967 wiring question

Jim, here's a recent post regarding a miswired power window relay. It sounds like you could have the same problem. The relay shouldn't click when you connect power, it should only click when you operate one of the window switches. https://www.camaros.net/forums/showth...t=power+window





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Painless Wiring Question & Opinions MrDanB Electrical & Wiring 7 Apr 4th, 07 10:00 PM
69 Wiring Question SCHOON Electrical & Wiring 3 Jan 19th, 06 05:59 AM
A Question For Wiring Guro's Tom M Electrical & Wiring 9 Jun 29th, 05 04:44 PM
Fuel Gauge wiring question? y-try Electrical & Wiring 2 May 18th, 04 04:01 PM
1967 Pace Car Question Jim N Tag Team 2 Oct 15th, 00 06:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome