Added HEI-Now Engine Won't Turn Off! - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Sep 26th, 07, 06:56 PM Thread Starter
Senior Tech
 
Join Date: Jan 2000
Location: Houston, TX USA
Posts: 797
Added HEI-Now Engine Won't Turn Off!

I recently added HEI to a '73 Nova that I am working on. I used the original resistance ignition wire to trip a relay. The power supply to the relay is a 12 gauge wire directly from the battery, and then another 12 gauge wire to the HEI.

When I turn the ignition off, somehow there is voltage back feeding to the HEI from the ignition wire. With the ignition switch turned off, the engine just keeps on running.

The only way I can turn it off is to pull the ignition 12V+ wire off of the relay, and then the motor shuts off.

I have read on this site previously about having to add some type of resistor, or some other Radio Shack provided piece of equipment (diode?) to fix this issue.

Can someone please tell me what I need to do to fix this? Thanks very much!

1969 383CI, T-56, 12 bolt-3.31 posi, 13" C5 Rotors, PBR Calipers, rear disc system..
Go69 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Sep 26th, 07, 07:05 PM
Senior Tech
Charlie
 
Join Date: May 2007
Location: Baltimore Maryland
Posts: 3,759
Re: Added HEI-Now Engine Won't Turn Off!

HEI does not use the resistance wire.

Charlie Knudsen 67 Camaro RS/SS 350 TKO 600, 4.10's, AFR 195 Street Heads, Comp 270H, Rhoads Lifters, Crane Ignition, Pertronix Dizzy, Performer RPM Q-Jet, Heavily Modified Q-Jet, Hooker Comp Headers, MagnaFlow 2 1/2", 144 Decibles(Alpine CDA-7998 Head Unit, RF X7 and RF 750X Amps, MB Quart Mid's & High's, Kicker L7 12" Solo Barics)
67CamaroRS/SS is offline  
post #3 of 9 (permalink) Old Sep 26th, 07, 09:17 PM
Gold Lifetime Member
Strick
 
Join Date: Sep 2006
Location: Reno NV
Posts: 824
Re: Added HEI-Now Engine Won't Turn Off!

http://www.msdignition.com/pdf/6%20series/6series.pdf


Read page 8 of 24 in the pdf file.

It explains it well, as well as the fix.

Strick
'67 'Vert (408" SBC), V-Rod, Street Glide, and too many other motorcycles to list.
Strick is offline  
 
post #4 of 9 (permalink) Old Sep 27th, 07, 12:54 AM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Re: Added HEI-Now Engine Won't Turn Off!

Quote:
Originally Posted by 67CamaroRS/SS View Post
HEI does not use the resistance wire.
he is using the resistor wire to trigger a relay that powers the HEI.
seems like a good way to get max power to the coil.
i can't see how the current going thru the power wire from the battery could keep the car running, unless the alternator power feed is somehow on the same side of the relay as the coil.

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
post #5 of 9 (permalink) Old Sep 27th, 07, 02:08 AM
Senior Tech
 
Join Date: Jul 2001
Location: Pontiac IL
Posts: 453
Send a message via AIM to undee72Z
Re: Added HEI-Now Engine Won't Turn Off!

Quote:
Originally Posted by Go69 View Post
I recently added HEI to a '73 Nova that I am working on. I used the original resistance ignition wire to trip a relay. The power supply to the relay is a 12 gauge wire directly from the battery, and then another 12 gauge wire to the HEI.

When I turn the ignition off, somehow there is voltage back feeding to the HEI from the ignition wire. With the ignition switch turned off, the engine just keeps on running.

The only way I can turn it off is to pull the ignition 12V+ wire off of the relay, and then the motor shuts off.

I have read on this site previously about having to add some type of resistor, or some other Radio Shack provided piece of equipment (diode?) to fix this issue.

Can someone please tell me what I need to do to fix this? Thanks very much!
Most likely power from the GEN lamp is keeping the relay closed and causing the engine not to turn off. You need to add a diode. See the link Strick posted.

Greg U

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
undee72Z is offline  
post #6 of 9 (permalink) Old Sep 27th, 07, 05:54 AM
Gold Lifetime Member
Bruno
 
Join Date: Oct 2000
Location: Puerto Rico
Posts: 2,118
Re: Added HEI-Now Engine Won't Turn Off!

Or an electric cooling fan, generating enough power to...

"Our affair with Camaros is a life sentence without the possibility of parole".
ORENCH is offline  
post #7 of 9 (permalink) Old Sep 27th, 07, 01:25 PM Thread Starter
Senior Tech
 
Join Date: Jan 2000
Location: Houston, TX USA
Posts: 797
Re: Added HEI-Now Engine Won't Turn Off!

Thanks everyone for the input.

To clarify-the car does not have an electric fan. The gen lamp wire from the alternator is the problem based on the information found on page 8 of that MSD instruction sheet. Thanks Strick! This cars alternator is internally regulated, so the wire coming from the alt. is the one that gets the diode.

Now the next question, does anyone know what type, color, size, wattage diode that is needed? I would like to head over to Radio Shack to see if I can pick one up.

Thanks again for the FAST & informative responses!

1969 383CI, T-56, 12 bolt-3.31 posi, 13" C5 Rotors, PBR Calipers, rear disc system..
Go69 is offline  
post #8 of 9 (permalink) Old Sep 27th, 07, 01:33 PM Thread Starter
Senior Tech
 
Join Date: Jan 2000
Location: Houston, TX USA
Posts: 797
Re: Added HEI-Now Engine Won't Turn Off!

Okay, disregard the request for info on the Diode. It is CLEARLY written on that diagram from the MSD web site. I just needed to slow down, and read what was in front of me.

This site remains, as it always was before, the very best.

Thanks again everyone for your time and effort.

1969 383CI, T-56, 12 bolt-3.31 posi, 13" C5 Rotors, PBR Calipers, rear disc system..
Go69 is offline  
post #9 of 9 (permalink) Old Oct 5th, 07, 11:23 AM
Gold Lifetime Member
Steven
 
stamatisg1977's Avatar
 
Join Date: Sep 2005
Location: Mastic Beach Village, NY
Posts: 3,030
Re: Added HEI-Now Engine Won't Turn Off!

my engine has run on too. i have the e-curve distributor but it did not come with a resistor. do i need one for my type of distributor?

69 Frost Green Camaro
LS3 with TSP stage 3 cam
Tremec TKO 600
Moser 12 bolt rear with ford ends 3.73:1 Eaton tru trac differential
Speedtech pro touring subframe
Ridetech rear 4-Link


Follow my journey here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stamatisg1977 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome