Turn Signal - Team Camaro Tech
Electrical & Wiring Troubleshooting electrical.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Oct 21st, 07, 07:57 AM Thread Starter
john
 
Join Date: Aug 2007
Location: Omaha
Posts: 4
Turn Signal

Finally solved my turn signal problem on my 67RS after a number of years and wanted to share the solution in case someone else has the same problem.

When I bought my Camaro in high school, 1983, the turn signals didn't work at all. I replaced the flasher plugged into the fuse box and the turn signals flashed although very slowly. This made me a bit nervous but got me through high school.

20+ years later, with the Camaro in storage most of the time due to lack of time or money, it was time to get this fixed once and for all. Of course now they didn't work at all anymore.

Changed the flasher located in the fuse box again, still nothing. Checked and replaced every non working bulb in the car, fixed some loose tail light sockets, still nothing. I read every post on this site and couldn't find anything specific that would solve the problem. Started thinking that it must be the turn signal switch because I couldn't find any ground or short problems so what else could it be?

Well fortunately, have a brother who is an electrician by trade. We broke out every wiring diagram we could find and he started troubleshooting with his voltmeter. Well two hours later we found a second flasher unit underneath the dash that didn't show in any of the wiring diagrams. It is a square, two pronged unit plugged into to a socket underneath the dash just to the right of the steering column. The writing on the flasher says "Signal-Stat 145, 3 Lamp LL". We plugged a new flasher in this plug and a $2 part solved a 25 year old problem and the signals work perfectly.

I'm not sure if this is an RS specific piece but it doesn't show on any diagram I have and I have collected every Camaro book possible over the years.

Hope this helps someone else. Good luck.

John
jmoore2320 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Oct 21st, 07, 09:03 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Turn Signal

hmmmm..... that is the normalk turn signal flasher location on all firstgens.

The flasher in the fuseblock is only for the hazards.

Weird thing about wiring diagrams is the generally don't show where something is located.

Glad you gotter fixed!





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome